Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 7 64-bit. Logged in to the windows machine with cached networks credentials.

I'm trying to access a samba share on the current network. The Windows machine is logged in to "itself" with cached credentials from a different network domain.

When I try accessing \server\share on my current network, I immediately get the message that I don't have permissions to access the share. I get no login prompt, so I'm guessing that windows insist on using the credentials I'm logged in with to access the share, which naturally won't work.

I even managed to "add a new network credential" somewhere, where I added the server and share, and the correct username and password. Didn't help, not even after rebooting the machine. And now I cannot for the life of it find where I did it.

Any ideas on how to get around this?

share|improve this question
    
I posted it in SO by mistake, I'm afraid, thinking I was posting it in here. – Frank Oct 19 '12 at 11:31
    
Ah, Ok. Just wanted to confirm you were a real person. – Journeyman Geek Oct 19 '12 at 11:32
    
Are you the admin for the Samba share? If so, have you added the user to the /etc/samba/smbpasswd file? – slafat01 Oct 19 '12 at 12:39
    
Yup. I'm accessing the samba share from another linux machine, as well as from a mac. – Frank Oct 19 '12 at 18:02

"I don't have permissions to access the share" usually means the credentials did work, but that particular account is, well, not permitted to access the share...

To specify different credentials, try:

net use \\server Username * /savecred
share|improve this answer
    
Well, to be precise (using equivalent examples): The windows computer logs on to a domain, using the credentials user/pass. When not connected to the domain network, I log in with the same cached credentials. When I come home, I connect to a wlan and no domain/workgroup. The server in question is a linux server running samba, and the samba share has the following user credentials: bruker/passord. When I try to access the share, I get the above mentioned error. Of course the credentials don't work - they're no the right ones. The problem is, however, that I have no option to actually specify – Frank Oct 19 '12 at 17:05
1  
credentials - windows just assumes them, and never asks. I'll try accessing it with net use, however. Thanks for the tip. – Frank Oct 19 '12 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .