Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Previously I had an old Seagate barracuda 160GB HDD which got crashed some days before. Yesterday I bought new Hard Disk Seagate Barracuda 500GB (ST500DM002).

I just replaced the 500GB hard disk with 160GB one leaving data and power cable intact and untouched. And ideally this new hard disk should start functioning. I tried to install Windows 7 with DVD the setup says you don't have any hard disks installed on your machine. I rechecked connection tried with Win XP setup but continued receiving same error. Do I need to do some initialization stuff with hard disk before installing setup?

If so how to do it. If not then is there any problem with my newly bought hard disk?

Thanks In Advance.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

There might be some troubles.

I am guessing, that your 160GB HDD was sata too. In any case, you should check if your new HDD is shown in your BIOS - if not, and you are a 100% sure, power and data-cables are correctly attached and functioning (sometimes it might be the cable it self!) - then your new disk is probably defect.

You could try to test this by listening closely - you should be able to hear the spin-up and some clacking, but if not or you hear some uncomfortable repeatedly clacking, it is a bad sign.

You could try some linux boot-up disk, to confirm with it too.

Not knowing about your SATA-Controller, it might be a problem too - at least with XP you had to sometimes make a custom Boot-CD with included SATA-Drivers (had to do so on my Lenovo Laptop i.e.) otherwise, you would not see any hard disk.

share|improve this answer
    
I checked in BIOS it wasnt there, then I removed and attached cables again and it worked thanks. –  Akshay Kulkarni Oct 21 '12 at 6:40
add comment

Check in BIOS.
If its not there, something is wrong with MoBo/Cables/Jumper/the disk itself.

If it is there, get GParted live CD and boot from it. Manually partition the harddisk and see if windows can detect it then.

EDIT
ahh yes and change SATA mode in BIOS from AHCI to IDE

share|improve this answer
    
SATA drives do not have jumpers. –  slafat01 Oct 19 '12 at 12:45
1  
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.