Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Notepad++ and opened a php file using open with, I then checked off Always use selected program to open this kind of file in windows. The file has a notepad icon. How can I change this icon to a custom one?

** Update ** The files with regular notepad icons are on a secondary drive not my C: drive. I just looked at php files on my C drive and they have the association. Any idea what I can do?

share|improve this question
    
when you use the Windows "choose program" or "open with" to assign associations, it always chooses a weird default icon. Try doing associations in the native program's settings. – cloneman Oct 19 '12 at 18:02
    
I also tried going to Tools - Folder Options - File Types, and set all PHP files to use Notepad++ but they still have the default windows notepad icon. – Anagio Oct 19 '12 at 18:09

It seems like you'd probably have to edit the registry or download a program that basically edits the registry for you. Here's an example: http://www.sevenforums.com/tutorials/57455-file-extension-icon-change-default-icon.html

share|improve this answer
    
Not sure what the problem was but started working after changing the file types in Windows for CSS, JS as well as the settings in Notepad++ something wasn't refreshing but took affect and now I have the icons. – Anagio Oct 19 '12 at 20:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .