Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Synergy 1.4.10 on Ubuntu 10.10 as the server and on Windows 7 as the client. The problem that is happening right now is that the copy action on Windows has no effect to bring that text into the paste buffer on either Linux or Windows. That is, I cannot even copy/paste within Windows itself. Every paste attempt in either Windows or Linux gets the data last copied from Linux (or nothing if I have just booted both machines).

I was sure this worked when I first installed it. I have been assuming I broke something. But the configuration is so simple I see nothing in there to mess with.

On Linux (server mode) I have (desktop is Linux, laptop is Windows):

section: screens
    desktop:
    laptop:
end

section: links
    desktop:
        right = laptop
    laptop:
        left = desktop
end

section: aliases
    desktop:
        lorentz
    laptop:
        phoward-530
end

But maybe it was only Linux to Windows that worked (what I usually need to do most). But I do need to do copy/paste in other ways sometimes, so finding what is wrong here would help.

The only similar question that seems to match mine was for an older Synergy (1.3.5) that was stated by one comment as fixed in 1.3.6. But I'm on 1.4.10. Regression, maybe?

share|improve this question
    
I had it working perfectly on 1.4.6, upgrading to 1.4.8 broke it utterly, but my recent upgrade to 1.4.10 fixed it again (SUSE 12 and Win 7). I did have to completely uninstall it on Windows and reinstall the new version though. If you look through Synergy's forums, copy/paste issues have plagued it for many, many versions. –  MaQleod Oct 19 '12 at 23:39
    
From a number of things I've read, it seems other programs in Windows play around with the copy/paste and goof things up, it seems. I'm wondering if uninstall and reinstall will fix it. A full reboot of both systems at the same time did not. I have not installed anything new on Windows since Synergy. –  Skaperen Oct 20 '12 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.