Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to do a IPv6 multi-cast ping from Linux and I can't get a response from my windows host.

ping6 -I eth1 ff02::1 Will find all my Linux and iOS devices but not my Windows hosts. I can find my windows hosts using ip -6 neigh or just straight up pinging with their link-local address.

Do I need to enable or disable something to get them to respond?

share|improve this question
1  
I can confirm this on my computer as well. Disabled Windows firewall and still no response. Won't even reply to the echo from local computer. Very interesting behaviour. –  billc.cn Oct 19 '12 at 22:54

1 Answer 1

up vote 2 down vote accepted
+100

Windows has Connection profiles like "Private", and "Guest or Public" which manages if you can ping windows, or not.

You can see which profile is enabled for you with:

Control Panel\Network and Internet\Network and Sharing Center

and click "Advanced sharing settings"

There you see wheter the "Private" or the "Guest or Public" Profile is enabled.
Beside the enabled Profile name is (current profile), that marks it as active.
Inside the Profile enable "File and Printer sharing". And click "Save changes"

The "Guest or Public" profile is set to not respond to ping per default.
The "Private" profile responds to the ping by default.

To set the Connection Profile with powershell (in elevated mode) to Private use:

Set-NetConnectionProfile -InterfaceAlias "*" -NetworkCategory Private
share|improve this answer
1  
Hmm. This did not work for me on Windows 8.1. Despite being on a Private network with File and Printer Sharing enabled, Windows still does not respond to multicast pings. –  Michael Hampton Aug 2 at 20:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.