Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7 64 bit, in my playback devices, I used to have Stereo for speakers and headphones. I upgraded my drivers to RealTek's latest, restarted my PC, and I lost the headphone playback device.

If I unplug the headphones, the sound automatically transfers to the speakers and vice versa, but it was convenient to use that instead of plugging and unplugging headphones.

Is there any way to get that back?

share|improve this question
1  
Roll the driver back to your previous version? Unless you had any specific problems with it, of course. –  Indrek Oct 19 '12 at 23:34
    
I upgraded the driver for the equalizer and better control of digital output, which I didn't have before. It would be great to not have to choose, but I slightly prefer the sound of the new drivers. –  Jeff Oct 20 '12 at 1:25

1 Answer 1

This is happening because your settings are set to detect front panel jack inputs. This is optional with HD compliant front panels.

You can disable front panel detection and this should put the headphone tab back into your selection and then you can toggle your default output.

Open Realtek and click the folder (here circled in red).

A pop up for Connection settings should appear.

The Disable front panel jack detection box needs to be checked. Click OK.

You should now have HD Audio 2nd output tab with a headphone image in your tabs to select.

You can then Right click between the headphones or speakers to set up as the deafult output device.

disable front jack

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.