Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble running a program which should be on my $path, but apparently isn't. When I run it with the full path, it works fine, but when I only call the executable, it says command not found. This is despite the directory being on my path. Permissions are fine as far as I can see, and I have tried moving it into several different locations without luck.
Here is a snapshot of the issue, minizinc is the executable in question.

$ echo $PATH
$ minizinc
minizinc: command not found
$ /usr/local/minizinc/bin/minizinc 
minizinc: no model file specified
minizinc: use --help for more information.
$ ls -l /usr/local/minizinc/bin/minizinc 
-rwxr-xr-x 1 root root 2747036 2012-10-20 12:51 /usr/local/minizinc/bin/minizinc

I'm running ubutnu 11.04, and using bash as my shell.

share|improve this question

closed as too localized by slhck Oct 20 '12 at 6:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

What do you get if you execute: type minizinc? Could a minizinc executable be in /usr/local/heroku/bin that is for a different platform is missing a required shared library? I only ask that because I was burnt by this myself. – HeatfanJohn Oct 20 '12 at 2:25
$ type minizinc just gives bash: type: minizinc: not found. There is no conflicting file in /usr/local/heroku/bin unfortunately :( – Andrew Oct 20 '12 at 2:39
Welcome to Super User, Andrew! Since your problem just stemmed from a typo, I've closed this question as being too localized now – it's unlikely someone else will run into the exact same issue. Glad you got the problem figured out though! – slhck Oct 20 '12 at 6:43
up vote 2 down vote accepted

You have a typo in your path:

$ echo $PATH

You appear to be missing an i in minizinc in /usr/local/minzinc/bin.

share|improve this answer
oh my god, I feel like a moron. Thanks! – Andrew Oct 20 '12 at 2:52
Not at all. It happens to everyone. – Nicole Hamilton Oct 20 '12 at 2:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.