Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is i like to listen to videos online (mostly or all flash video) while programming and never had any problems until i started using eclipse, now every time i do just about anything other than type, it makes the video skip/freeze really bad and is really annoying. I have never had this happen using visual studio, netbeans, or adobe flash for that matter, unless i was compiling or doing something that hogs the processor.

Are there any settings that might could fix this its getting really annoying. it happens almost every time i even click "find" on the find pop-up window and it is not like it is having to search a big file or anything it is only 700 lines, with honestly only about 1/2 that have content on them. Any ideas?

share|improve this question
    
What version of Eclipse are you using? I haven't had videos playing at the same time, but if you're using Juno, I've noticed that it definitely has more lags (for example, while editing code or moving internal windows) than the 3.x versions (often enough that I'm considering rolling back to 3.8). –  Ash Oct 20 '12 at 5:15
    
4.2, not sure its code name –  RustyH Oct 20 '12 at 5:19
    
The codename for 4.2 is Juno. –  Ash Oct 20 '12 at 5:46
    
so nothing i can really do then unless i want to start all over with a 3.x? –  RustyH Oct 20 '12 at 7:24
    
I don't know. There are various options for tuning Eclipse (for example, by upping the memory allocated to it in eclipse.ini), which might help. It might be worthwhile installing a 3.8 somewhere just to try out. –  Ash Oct 20 '12 at 8:38
show 2 more comments

1 Answer 1

The reason for this is precisely as you mentioned:

I have never had this happen using visual studio, netbeans, or adobe flash for that matter, unless i was compiling or doing something that hogs the processor.

Eclipse by default compiles automatically in the background. You can disable this behavior from the Build menu: make sure Build automatically is disabled.

Personally, I prefer automatic building, but I can understand that on older machines it may make things sluggish. Alternatively, if you have a multi-core processor, you may want to consider giving Eclipse core affinity.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.