Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Debian Squeeze on an old Dell Dimension 8300 box. It has an AGP Radeon HD 4650 card. I use this machine to mine bitcoins, and today I noticed that the machine had rebooted! My precious uptime!

Anyway, my miner wouldn't start, so I figured might as well update my graphics driver, maybe that would fix the issue. I went to amd.com and downloaded the newest driver (12.6 legacy), but after installing it, aticonfig gave an error:

aticonfig: No supported adapters detected

I uninstalled the driver and figured I'd try to install it from apt. AMD has dropped support for the HD 4000 series in fglrx, forcing me to use fglrx-legacy-driver (currently only in experimental). In order to install this, I had to update libc6 (and some other important packages, like gcc), I had to use their wheezy versions. I finally got fglrx-legacy-driver installed, but I still got:

aticonfig: No supported adapters detected

Why isn't the driver finding my video card? I have a hunch it has something to do with the fact that it's an AGP video card.

Here is the output of lspci -v (why does it say Kernel driver in use: fglrx_pci?):

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730 Pro AGP [Radeon HD 4600 Series] (prog-if 00 [VGA controller])
    Subsystem: Advanced Micro Devices [AMD] nee ATI Device 0028
    Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
    Memory at e0000000 (32-bit, prefetchable) [size=256M]
    I/O ports at de00 [size=256]
    Memory at fe9f0000 (32-bit, non-prefetchable) [size=64K]
    Expansion ROM at fea00000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] AGP version 3.0
    Kernel driver in use: fglrx_pci

EDIT: fglrx 12.4 seems to work. Thing is, since I am on kernel 3.2, I need to apply this patch to common/lib/modules/fglrx/build_mod/firegl_public.c. I thought ATI dropped support for the 4xxx series after 12.4. Why doesn't 12.6 legacy work?

share|improve this question
    
Is it possible that I overheated/killed the card? How can I test this? –  Rocket Hazmat Oct 22 '12 at 14:20
    
I realized that kernel 3.2 might not support fglrx. I'm running 3.2.0-0.bpo.3-686-pae. –  Rocket Hazmat Oct 22 '12 at 15:21
    
fglrx 12.4 works just fine. Only thing is, I need to apply this patch to common/lib/modules/fglrx/build_mod/firegl_public.c first. –  Rocket Hazmat Oct 25 '12 at 4:40
add comment

1 Answer

up vote 1 down vote accepted
+50

Experimental drivers are called "experimental" because they are unstable and not efficiently tested. As a result, weird problems, errors and glitches can result. With this in mind, I suggest you try an earlier stable version (i.e. the latest stable release, rather than the latest release in general)

Good luck, hope this works! If not, leave a comment and I'll look further into it.

share|improve this answer
    
I got 12.4 to work correctly. That was the last one (before legacy) that supported my card. –  Rocket Hazmat Oct 29 '12 at 2:33
    
are you able to apply the patch on 12.4? or is that why you need 12.6 to work? –  Sylvester the Cat Oct 29 '12 at 2:46
    
In order to get 12.4 to install, I need the patch. I only wanted 12.6 because 6 is bigger than 4 :-P –  Rocket Hazmat Oct 29 '12 at 13:32
    
oh ok, so problems solved then? –  Sylvester the Cat Oct 29 '12 at 22:43
    
I guess. 12.4 seems to work. It'd be nice to figure out how to get 12.6-legacy working, though. –  Rocket Hazmat Oct 30 '12 at 13:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.