Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an early 2009 17" MacBook Pro. I was very impressed with it until deciding to connect my earphones. I can hear a continual background hiss that 'clicks' in when audio starts and then clicks off when audio stops (after a short while).

This may be exacerbated as they are noise-cancelling Sennheiser earphones. However I also use them very often on my iPod Touch and never notice this at all - even in the quiet at home.

I called up Apple who said to take it into a store for the staff there to listen. Firstly it's quite a trek for me to get to an Apple store, secondly I'm not sure how they could hear this given the noise in those stores, and thirdly there's no way I'm letting a complete stranger use my earbuds!!

Has anyone else experienced this and knows how to fix it? I tried posting on the Apple forums but only found "me toos" but no solutions.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

I have the same issue on my 13", and the solution for me was to change headphones.

The noise is audible over phones with very low impedance. When I use those I can hear the click and noise you describe, very clearly even at low volume. When I use phones with high impedance the problem disappears, even at maximum volume.

I don't think this is an issue with our mabook pros, I think they are all like this. The audio interface is not primarily made for earbuds, perhaps? Find some high impedance phones and give it a try.

share|improve this answer

Ok I know that this thread is not newest one, but had this problem and in my situation the hissing and crackling background noise was very distinct especially on the beginning or at the end of the track or during the quiet parts. During song it was masked by music.

I found this advice on one of gadzillion boards I have checked : go to Audio MIDI Setup (just type it in spotlight) and in Build-in-output change format (on the right side of window, next the 44kHz option) from 16bit to 24bit.

The hissing sound has vanished almost completely (you can still hear a difference between total silence and when song start playing, but it is bearable).

Hope this helps.

share|improve this answer
    
@Jacob: Thanks, I didn't know about these settings! Unfortunately mine were already set to 24-bit. I might play with them to see if it makes a difference though. –  Alex Angas Feb 8 '10 at 11:59
    
Thanks. That totally helped. It also works when setting it to 32-bit. What is the advantage/disadvantage of using 24-bit instead of 32-bit? –  znq Oct 12 '10 at 10:49
    
Your answer made me so happy I registered for this site just to thank and upvote you. Life changing! –  llimllib Nov 10 '10 at 3:31

I had the exact same problem. I found this thread: http://forums.macrumors.com/showthread.php?t=329183 and they recommended the Shure Level Attenuator Volume Control EA650. You can find it on Amazon for $20 which, IMO, feels like a ripoff.

However, it actually works. I use it constantly. It's the only way I can listen to music on my MBP without a ringing in my ears afterwards.

share|improve this answer
    
This worked perfectly for me with Shure SE 535s...the adapter is included when you buy them. –  DD. Jan 14 '12 at 9:50

could be interference from the spinning hard drive. have you tried playing songs from a USB stick (without any disc activity)?

share|improve this answer
    
This is a problem with laptops. To eliminate it, either try different headphones or get a USB sound card. Get the digital to analog conversion away from the laptop. –  Mike Wills Sep 30 '09 at 18:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.