Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

About a month ago I attempted to remove a vulnerable version of the Java Runtime Environment (JRE). Unfortunately, I didn't know there was another user logged in at the time. This caused the uninstallaion to fail. Since then, the system has had a broken JRE that cannot be removed or replaced. The windows installer fails with unhelpful generic error messages, event viewer is worthless, and javara does not log anything. Does anyone have any other suggestions, short of a complete system rebuild?

share|improve this question
Have you tried the manual method already, i.e. digging through the registry for all instances of java, jre, sun/oracle and so on? – Karan Oct 20 '12 at 20:39
No. I was afraid of making a bad problem worse. – Sean W. Oct 20 '12 at 23:08
up vote 2 down vote accepted

Based on the suggestion of Sorean, I looked at the support page for MSIZAP. In the comments for that page, Jeff Ingalls (a Microsoft employee) states:

MSIZAP and MSICUU2 are no longer supported because they have been found to cause problems. Please use the Program Install and Uninstall troubleshooter available here:

I used the Program Install and Uninstall Troubleshooter to remove the broken JRE. I was then able to install the updated JRE as normal.

share|improve this answer

You can attempt to use MSIZAP to remove the install from your registry and then manually delete all the files and then install the new version of JRE.

Be careful with this utility though, you don't want to zap the wrong install or zap a program you still want.

share|improve this answer
It seems that MSIZAP and MSICUU2 are no longer supported by Microsoft. Your answer helped lead me to the Program Install and Uninstall Troubleshooter that solved the problem. Thanks! – Sean W. Oct 20 '12 at 23:41
It could still be used even though it's no longer supported. But I'm glad you found your solution. – JKM Oct 21 '12 at 0:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .