Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I right-clicked into an .exe file then chose Open with... and I select choose a program then I selected the wrong program. I checked the checkBox that has the label Always use the selected program to open this kind of file.

Now all of the .exe files have changed into the wrong program after I did this, so all .exe file opened with this program.

How do I revert the .exe file associations to do my regular work?

share|improve this question
Interesting. Even holding down Shift I don't see this option for .exe files. Can anyone else reproduce this incredibly-useful windows feature? – RJFalconer Mar 18 '15 at 17:39
Create a link to an .exe file and right-click on it. Worked for me. – Dmitry Grigoryev May 25 '15 at 1:59
I've voted to reopen this question so that we can switch the dupe direction between this and this other question, since this one has better answers. – Ben N Jan 25 at 0:53

Paste the following into notepad

Windows Registry Editor Version 5.00





In notepad On the File menu, click Save as

Select All Files in the Save as type list, and then type Exe.reg in the File name box. Select Unicode in the Encoding list. Save it and remember the file location.

Go to the file location and right click on the EXE.reg file and select "merge"

Restart the PC.

For alternative ways to fix this issue and a bit more info view this page from Microsoft

share|improve this answer

Back up the registry

  1. Go to Start, type regedit and press Enter.
  2. Navigate to the following key: HKEY_CLASSES_ROOT\.exe
  3. In right-side pane, change the value of the Default key to exefile.
  4. Now go to HKEY_CLASSES_ROOT\exefile\shell\open\command
  5. In right-side pane, change the value of the Default key to: "%1" %*.
  6. Now exit Registry Editor and restart your Windows.

See if this helps in opening applications with their respective program. (answer found here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.