Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Samba 3, and want to join my Windows 8 PC to the Samba domain.

Windows 8 cannot join out of the box, so I added the following registry entries:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
        DWORD DomainCompatibilityMode 1
        DWORD DNSNameResolutionRequired 0 

And now it talks to the Samba server ok, however I get the following error: Samba Windows 8 error

And I notice that the machine name created on the samba server does not match its name:

win-8jq3fg1n74e$:x:30003:30003:Machine:/var/lib/nobody:/bin/false

It is like it is using an internal name.

The following is the error in the smb.log

[2012/10/21 14:26:16.099520,  0] passdb/pdb_interface.c:348(pdb_default_create_user) _samr_create_user: Running the command `/usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false win-8jq3fg1n74e$' gave 9        
[2012/10/21 14:26:28.143224,  0] lib/util_sock.c:474(read_fd_with_timeout)
[2012/10/21 14:26:28.143420,  0] lib/util_sock.c:1441(get_peer_addr_internal)
  getpeername failed. Error was Transport endpoint is not  connected
  read_fd_with_timeout: client 0.0.0.0 read error = Connection reset by peer.
share|improve this question
    
What do you mean can't join out of the box? Are you using Windows 8 core, not Pro, or is there something else wrong? –  nhinkle Oct 21 '12 at 4:03
    
@nhinkle I mean in the same way that Windows 7 cannot join a Samba domain out of the box - Samba3 supports NT type domains, and W7 and W8 so needs the registry settings above before you begin. –  Paul Oct 21 '12 at 4:06
    
Ahh, I see. So it's an issue of backwards-compatibility then. Thanks for clarifying. –  nhinkle Oct 21 '12 at 4:24
add comment

2 Answers

up vote 5 down vote accepted

There are two things I did to get this to work, though I believe the first might be all that is required:

  1. It appears that while you set the machine name fairly early on in the setup, it doesn't actually take until another reboot. So internally it is win-xxxxxxxxxxx until a reboot where it then takes on the machine name defined in the Computer Name dialog above.

  2. Setting a primary suffix in the Computer Name dialog

With the registry settings in the OP and an additional boot (and possibly ensuring there is a suffix), joining Samba domains works fine.

share|improve this answer
    
I think changing the computer name while your are joining seems to be a fairly common mistake. You change the system name, reboot, then join, reboot. If you attempt to change the system name while joining a domain - it will attempt to use the old system name to join and Bad Things Will Happen (tm). –  Nathan Adams Oct 22 '12 at 18:05
    
The computer name wasn't changed during joining. –  Paul Oct 22 '12 at 20:53
add comment
[2012/10/21 14:26:28.143224,  0] lib/util_sock.c:474(read_fd_with_timeout)
[2012/10/21 14:26:28.143420,  0] lib/util_sock.c:1441(get_peer_addr_internal)

I had the same problem. I had probably broken the relation between user and group.

I deleted user and group, created new ones, and it was OK.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.