Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a folder in Windows 7 ( my Music folder in Libraries ) in which suddenly all files became inaccessible.

When I try to play a music file or just view album cover all programs give me an error about unable to read the file.

First I checked all permissions and everything seems ok. My user have full access over this folder and all enclosed files.

Then I noticed that when I reboot in Debian I can read all files.

When I copy a new file to the folder I can read the new file but still not the old ones.

I noticed that when I copy a file from Music folder to the Desktop I can read it, but still not when it is placed inside the Music folder.

Do you have any idea what can I do to be able to read the files ?

P.S. I just noticed that despite I am the owner of the folder and I have full access, when I view the properties of a single file my user is not in the list of users who have access to the file. When I add my user everything is ok, but I cant to this file by file. Any way to apply this permissions to all files ?

share|improve this question
    
Have you tried ICACLS? –  soandos Oct 21 '12 at 8:28

2 Answers 2

up vote 0 down vote accepted

You can do this with ICACLS or powershell (see here for more, the CMD way is much simpler/faster)

share|improve this answer
    
Seems like just "icacls Music /reset /t" did the job. Thank you all who tried to help –  gotha Oct 21 '12 at 8:42

In the advanced section of your folder permissions (Music folder) enable inherited permissions for child objects.

Something to that effect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.