Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While I was entering my password in Gmail and other mail accounts, I could see a symbol of an "eye" in the text box.

This is really dangerous because once you click on the eye, your password is revealed.

Is there any way I can disable that eye symbol? I'm getting this in Internet Explorer. Has anyone else encountered it?

share|improve this question
This happens to be one of my favorite features in Windows 8, and removes the illusion of security provided by 'little dots'. – Tanner Faulkner Oct 21 '12 at 16:12
There is some security provided by the 'little dots' - malicious software taking screen shots or someone standing behind you can otherwise read the password. – markmnl Jan 14 '14 at 7:03
@markmnl If you got a password stealing malware product on your computer, I'd assume it uses something more reliable than a simple screenshot (which would need OCR or human intervention and only works when the password is visible), like keylogging or any browser based attack. Even social engineering would be more reliable. – Nzall Jan 14 '14 at 15:21
@NateKerkhofs malware has used this technique in the past so it is not detected by anti-malware that would block key-logging - security is all about preventing all vulnerabilities otherwise there wouldn't be much point - should a prison only have guards at the main gate :) – markmnl Jan 15 '14 at 1:25

The new 'eye' symbol is present in all the password fields in Internet Explorer 10 which comes default with Windows 8 (and is also available for Windows 7). To reveal the password, the user needs to keep the 'eye' symbol pressed.

Disabling it (in Windows 8):

Please note that to do the following, you will need to access the Local Group Policy Editor, which is only available in Windows 8 Pro. You can see if you have Windows 8 Pro by pressing Win+Pause, which opens the System Properties window. If under "Windows Edition" you see Windows 8 Pro, you will be able to access the Group Policy Editor.

To disable the "eye" symbol, follow these steps:

  1. Open the Run dialog (Win+R)

  2. Enter gpedit.msc and press Enter

  3. Local Group Policy editor will open:

  4. Navigate to Computer Configuration → Administrative Templates → Windows Components → Credential User Interface:
    Option here

  5. Double-click on "Do not display the password reveal button" and select the "Enabled" option:

  6. The behaviour is disabled, you can enable it with the same method.

Source: Enable or Disable Password reveal option in Windows 8

share|improve this answer
You should note that "hiding" the password doesn't give any safety to anything but the person standing behind you while you type. So unless that person is handling the mouse to click the button no security has been breached at all. And even in all previous Windows versions passwords from "hidden" passwords fields can be trivially retrieved. – orlp Oct 21 '12 at 13:36
@AkshatMittal: yes, but you did not note the misconception in his question: "This is really dangerous because once you click on the eye, your password is revealed.". – orlp Oct 21 '12 at 13:47
@nightcracker I did note that, but the simple thing is he asked for 'How to disable it?' – Akshat Mittal Oct 21 '12 at 13:48
@nightcracker - I totally agree, getting the contents of a textbox in Windows is (was) very easy. In memory, most of the time, the password is stored in the clear. – Nathan Adams Oct 22 '12 at 17:58
strange that I can't find a place to go to Local Group Policy Editor without using a command line ... back to DOS times! – sergiol Apr 25 '13 at 12:09

You must log in to answer this question.

protected by Community Mar 23 '13 at 10:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .