Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to do a simple conversion using the following arguments from Fabio Sonnati's blog.

ffmpeg –i source.MOV –r 15 –s 320×240 –an video.flv

Getting this error

Unable to find a suitable output format for '–i'
share|improve this question
up vote 5 down vote accepted

The culprit lies in the blog post itself. The author used the en-dash instead of the hypen-minus (, not -), so FFmpeg will choke on that and not recognize i as the input option.

Moreover, the author used the multiplication sign instead of a latin x for the size (×, not x).

To fix this, replace the command with:

ffmpeg -i source.MOV -r 15 -s 320x240 -an video.flv

And go write the author a mail that they should fix their examples.

share|improve this answer
    
THANKS!! Will let Fabio know – eco_bach Oct 21 '12 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .