Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

With the d-link firmware I just connected the router and it worked, as is expected when using DHCP, but with dd-wrt I have no internet access.

It is configured with DHCP, and dd-wrt's wan status page reports that it is connected and that it has an ip address. Yet it is impossible to reach the internet.

If I disconnect the router and plugs the cable directly into my computer I get internet access, so it's obviously the dd-wrt software that isn't doing its job. However, I have no previous experience with the dd-wrt software and have no clue what to look for. I thought it would just work.

By the way, the power led is orange, the internet led is off, and wireless+lan1 is green. They all used to be green with the d-link firmware. Not sure if it's relevant, but now you know.

Does anyone have any idea what I should do to get internet access (besides reinstalling d-link's firmware)?

EDIT: It's a version B1. I read that it is very different from the A1 version, so I thought it may be relevant.

share|improve this question
I notice you don't mention the type internet connection (cable, etc) and if you are power cycling the modem when you switch from connecting it to the router and the computer. – Bon Gart Oct 21 '12 at 18:58
@BonGart The internet connection is a Swisscom DSL I think, but my router is behind another router, so I'm basically just connecting to a regular DHCP network. As far as the modem goes I haven't touched it since it's working. I'm using it right now. – Erik B Oct 21 '12 at 19:12
Had the same issue recently. DDWRT changed my router's MAC address to a different number, and it didn't play nicely with the ISP. Check the MAC address label on the router and compare it to the address in your DDWRT interface. If they aren't the same, look into spoofing your MAC address – Callen L Jun 10 '14 at 18:03

From what I've seen about dd-wrt, it's a "raw" distro. Meaning you have to configure stuff manually. The first step, after getting the external wan connection and setting up a DHCP, is configuring NAT.

I'm sure these guys know how to explain it better than me:

Read the docs. I'm sure it's all covered. After all, this is a distro -dedicated- to routing.

share|improve this answer
Based on my experience with DD-WRT this is generally not the case - while it has a lot of advanced features, it is still consumer-oriented and quite user friendly. In general you should be able to just plug in a DD-WRT router, set the username and password, and start using it, just like a regular consumer router. – tlng05 Dec 13 '14 at 18:16

As was mentioned in the earlier answer, the key here is manually setting up your internet connection in the router. The issue here is in how DSL modems work.

DSL modems typically have router firmware built into them. They tend to be hard coded to pass out a single internal IP address to a device that is connected to them. You typically see an address like or something similar coming out of the DSL modem, as opposed to an external IP address like or whatnot (I just created that randomly... I apologize to the holder of that address, whomever it may be... if anyone). What that means is if you check the IP address that is assigned to the computer connected to the DSL modem, it would be a Private Network address.

This means that when you connect a router to the DSL modem, you usually have to manually assign the gateway address of this Private Network to the router... if not also the internal IP address itself as well.

Otherwise, follow the link in the above answer, or use the DD-WRT Support site and follow their instructions for how to manually configure the router. You are essentially turning the router into a bridge... except you want the bridge to also handle DHCP.

share|improve this answer

Having a router behind another router is a complex setup that very often won't "just work" with the default settings. For example, if the existing router uses the same LAN address range as the new router uses by default, the setup won't work.

The best thing to do is just to go over every single setting in the new router to make sure it's correct. Before you do that, look closely at how the existing router is configured so you will know what the correct setup is for the new router. For example, if the existing router has a LAN range of, the new router will not be able to use that range on its LAN side.

share|improve this answer

Since the DD-WRT router is connected to another router and not directly to the modem, I don't think the modem or some kind of MAC filtering is the issue. The only thing I can think of that would cause a conflict is if DD-WRT is trying to distribute private IP addresses on the same IP range as the upstream router. For example, if the upstream router is handing out addresses between to, your DD-WRT router must hand out addresses in a different range, such as to It may have worked with D-Link firmware simply because the D-Link firmware just happened to distribute addresses on a different range by default.

To see if this is the issue, go to Setup->Basic Setup tab. Under the Network Setup->Router IP section set the Local IP Address to, which the upstream router is unlikely to be using. Save, Apply, reboot the router, and test the Internet connection again.

share|improve this answer

Ops we call that dirty NVRAM you problem more simple than that, make 30-30-30 reset that's all

  • With the unit powered on, press and hold the reset button on back of unit for 30 seconds
  • Without releasing the reset button, unplug the unit and hold reset for another 30 seconds
  • Plug the unit back in STILL holding the reset button a final 30 seconds after that don't forget to make DHCP auto and of course don't forget to change IPaddress to something different for example the second one

**NOTE:**some routers stuck and can't take auto DHCP until you make it static IP then change it to auto

share|improve this answer

I guess your problem is at the DNS settings! I think your router cannot get the specific domain's assigned IP Address. For example, if you access, the router has to get the real ip address of the server which is in this case. So, try and if it works, verify your DNS settings. Or, just set them manually on your machine (computer,etc), but this is not the proper way to do it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .