Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows 8 on my Sony VPCS111FM laptop. It has an ambient sensor that auto-dims the screen; this sensor is reliant on the video driver working.

The default video driver that came with Windows 8 does not play nice with the sensor, and as a result, my screen is at the dimmest setting. If I disable it and reboot, then the screen is bright, but I get a less-than-optimal resolution.

Google searches reveal that I'm supposed to install the windows 7 drivers Sony provided (as opposed to the Microsoft's default ones). When I install these using compatibility mode, nothing seems to be happening.

I googled around some more, and got Vaio Control Center installed. But the auto-dimmer setting option isn't found under "Display".

I know at least one person got this to work (see the link above), but I can't seem to figure it out.

Any ideas?

share|improve this question
I answered my own question. Can't put it in because I'm a new user, so putting it here. – Kevin Oct 22 '12 at 7:52
You should be able to self answer, even if you have lowish rep. – Journeyman Geek Oct 22 '12 at 8:08
@JourneymanGeek after 8 hours or so... – Sathya Oct 22 '12 at 8:12
@JourneymanGeek: Yes, it said I needed to wait some number of hours before I can answer. But it seems that I can do so now. – Kevin Oct 22 '12 at 8:20

2 Answers 2

up vote 2 down vote accepted

I solved my problem!

I figured this out by luck. Here's the outline of steps I followed.

  1. Download (search for it on Google. Here's a possible location.). Or, I uploaded it here.

  2. In the zip file, find and extra the folder named '64bit'.

  3. Download INDVID-00219009-0042.exe (Video driver update) from Sony's website.

  4. Disable the default Microsoft driver and boot into safe mode. Through device manager, manually install the driver in steps 1 & 2 by telling Windows to look for the .inf file at 64bit/Graphics.

  5. Reboot (the screen will be dark for the time being). Windows is asking for igfxTray module to be installed. Do so.

  6. Now install the driver downloaded in step 3. This should allow the monitor to be bright again.

I'll make an image of my PC now, and reinstall sometime to make sure this procedure works. Will report back when that happens.

share|improve this answer

I can confirm this solution. Many thanks to user12677 for discovering it. It couldn't have been easy.

My method, generally follow user12677 instructions but no need for safe mode.

  1. Download and INDVID-00219009-0042.exe as described by user12677.
  2. Unzip (extract) In extracted folder, navigate to 64bit/Graphics folder. Right click on igdlh64.inf file and select Install.
  3. Execute INDVID-00219009-0042.exe to install the Sony "undim" driver.
  4. Reboot and voila ... done.
share|improve this answer

protected by Community Dec 3 '12 at 1:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.