Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

8GB FAT32 filesystem that normally mounted as intended using usbmount. When I went to take it out to plug into a difference computer I did umount /dev/sda1 which is where it was.

Now it fails to automount either on boot or when I plug it in. When I run

sudo mount -t vfat -o rw /dev/sda1 /media/

it fails to mount with dmesg

[   15.204564] FAT-fs (sda1): bogus number of reserved sectors
[   15.214057] FAT-fs (sda1): Can't find a valid FAT filesystem

I presume I shouldn't have umounted then? How do I restore mounting (and automounting) of the drive? OS is Raspbian (Debian) on a RaspberryPi

share|improve this question
It's corrupted. Can't find a valid FAT filesystem – warl0ck Oct 22 '12 at 8:04
So it was. How would that have happened? It was working fine when I removed it correctly from my W7 workstation? – user1561108 Oct 22 '12 at 8:07
Have you tried running fsck on it? And does it work if you plug it into a Windows system? – ShankarG Oct 22 '12 at 8:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.