Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 8 machine is going to restart shortly...

enter image description here

I have tried a few techniques such as shutdown /a which is not having much luck.

Short of pausing the Windows Update service, is there anyway to stop this restart from happening?

---update---

Looks like the "restart" is all talk and no action! The time has gone and I am presented with this:

enter image description here

So, it goes along with the top answer here (which I shall shortly accept)

--- update again---

It did reset!!! My battery went critical and it turned itself off, I turned it back on (out of suspend) when it was plugged in, I logged in and the first thing it did was automatically restart - closing my open tabs in Chrome :(

Oh well...

share|improve this question
5  
The 'except' part is only true if W8 can actually detect that accurately. It can't - eg unsaved form content on web pages, custom apps, etc. Several times I've lost work due to this. –  Will Hughes Jan 14 '13 at 13:53
5  
thank you whoever chose this to be as a feature in Windows 8. I could no believe my eyes as it actually did reboot while I was working and I saw all my work disappear before my eyes. Somethings cannot be just saved. –  ericosg Jun 17 '13 at 4:12
    
Vista too will reboot while you're using it, at least under some circumstances. I'd recommend always setting the updater to require your acceptance to begin the update install. On Vista that's Windows Updates -> Change Settings -> "Download updates but let me choose whether to install them" –  Daniel R Hicks Sep 18 '13 at 20:26
    
if you are afraid of losing all your tabs in Chrome, there is a setting where all of your tabs in the last Chrome window open are saved, so that you can resume them when the computer is restarted or you open Chrome again. settings -> on Startup (section) –  Malachi Apr 22 at 17:51

3 Answers 3

up vote 77 down vote accepted

Updates are always welcomed, and I like to think in software as complex as the likes of Windows NT indicate good health, or at least the desire for resilience. So I say assume good faith in claims of urgency. But if they're destroying your work, here's some Group Policy that considers your situation.

Tested solution in upper-segment Windows

Take a look at the Group Policy settings for Windows Update in gpedit.msc, in particular No auto-restart with logged on users for scheduled automatic updates installations:

They are in:

Local Computer Policy
|-Computer Configuration
  |-Administrative Templates
    |-Windows Components
      |-Windows Update

Change "No auto-restart with logged on users.." to enabled. GPO No Auto-Restart


Essentials segment Windows users

acatalept contributes the following solution for users of products offering the essential NT experience.

For non-Professional versions of Windows that don't have Group Policy Editor (gpedit.msc), you can accomplish the same thing as above in the Registry Editor. Navigate to this node (you may need to run it as Administrator):

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU

There, create a new DWORD (32-bit) value named NoAutoRebootWithLoggedOnUsers and set the value to 1. Then reboot for the change to take effect. See Pete's Stop Windows 8 Rebooting Due To Updates for steps.

share|improve this answer
19  
This should be the accepted answer. The current accepted answer is completely false. After 2 prompts, which I closed, Win8 rebooted while I was still typing. When it came back up, I made sure to enable this GP setting. –  Kasey Speakman Jan 12 '13 at 9:30
4  
Based on the experience I just had about 10 minutes ago, this needs to be enabled before you get the 5 minute warning...probably before you get the 15 minute warning too. –  James Johnson Feb 16 '13 at 9:28
1  
I did that last time my computer wanted to restart on me, and thought I was fine, but a few minutes ago, I just got the 15 minute warning again –  Sam I am Mar 22 '13 at 15:17
1  
@Sam I made the change the previous time that it wanted to restart. my computer has restarted many times since then –  Sam I am Mar 28 '13 at 14:08
12  
@Martha @Louis For non-Professional versions of Windows that don't have Group Policy Editor (gpedit.msc), you can accomplish the same thing in the Registry Editor (regedit.exe) (you may need to run it as Administrator): under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU create a new DWORD (32-bit) value named NoAutoRebootWithLoggedOnUsers and set the value to 1. Then reboot for the change to take effect. See petenetlive.com/KB/Article/0000773.htm –  acatalept May 16 '13 at 13:51

I use the Session Buddy extension for Chrome to avoid this problem, and similar issues. It saves the state of all tabs open in Chrome so that they can be reopened later. It has saved me numerous times, highly recommended!

Session Buddy screenshot

This extension has also been very useful at work, where sometimes the IT guys force a reboot for a critical Windows Update.

share|improve this answer
2  
Why the downvote? @william-hilsum specifically complained about losing his tabs in chrome, and this extension solves the problem he experienced, just in an indirect manner. –  cmorse Oct 17 '13 at 17:53
    
Respectfully, I wish I could downvote too! -- The question was regarding preventing a restart -- most of us are here to prevent restarts. The OP gave an example of a reason why he'd want to do it -- but there are lots of other reasons why this problem needs to be solved. Your answer does not address ANY of those reasons, but only the one side effect. It's seriously not relevant to the problem. –  BrainSlugs83 Sep 3 at 6:36

Run services.msc, right-click the Windows Update service and stop it. This can prevent a scheduled restart even if you have been warned by Windows it will happen. Oddly enough, stopping the service with the NET STOP wuauserv command, does not seem to cancel restarting.
Of course, after a reboot, Windows can still restart. If you don't have access to gpedit.msc and thus can't apply Louis' more permanent solution, I suggest you go to Windows Update settings and set it to download automatically, but with manual install.

share|improve this answer

protected by Community Feb 17 '13 at 23:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.