Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I install windows 8 what version(s) of the .NET framework will be installed before any auto-updating?
What about after applying any automatic updates?

share|improve this question

4 Answers 4

up vote 28 down vote accepted

By default Windows 8 has .NET 4.5 installed. .NET 4.5 is an in-place upgrade for .NET 4. This means that you can run applications targeting .NET 4 and 4.5 by default on Windows 8. Also .NET 3.5 SP1 is available as a Windows feature in Windows 8. That means that all you have to do is go to Add and Remove Features and just select the .NET 3.5 SP1 feature and you will have .NET 2, .NET 3.0 and .NET 3.5 on your machine.

So in short, without downloading any installers, you have following .NET versions on a Windows 8 machine:

  1. NET 4.5
  2. NET 4.0
  3. NET 3.5 (Need to enable feature)
  4. NET 3.0 (Need to enable feature)
  5. NET 2.0 (Need to enable feature)

(Not sure if you can install .NET 1.1 on Windows 8. It was supported on Windows 7)

Edit: As per Graham Wager, we can install and use .NET 1.1 on Windows 8.

share|improve this answer
1  
.NET 1.1 does install and does work (for the application I tried it on at least), but throws up a compatibility warning upon launching the installer. –  Graham Wager Oct 22 '12 at 10:10

enter image description here

Windows 8 comes with .net 4.5 advanced services built in. If you install an application which needs .net 3.5 or earlier, it will automatically pull it in .net 3.5 as part of the install process - mine installed it when I was installing paint.net

share|improve this answer

Seems like .NET Framework version 4.5 is already installed as listed here.

Also on this page, under the "Instructions", there is a Note specified which says:

Windows 8 and Windows Server 2012 include the .NET Framework 4.5. Therefore, you don't have to install this software on those operating systems.

Typically, it includes these:

  1. .NET 4.5
  2. .NET 4.0
  3. .NET 3.5 (Need to enable this)
  4. .NET 3.0 (Need to enable this)
  5. .NET 2.0 (Need to enable this)

No official information has yet been provided by Microsoft.

share|improve this answer

Be advised....enabling .Net 3.5 from the control panel on a tablet machine such as the Micrsoft Surface pro will not work. To date Microsoft has not addressed this issue.

share|improve this answer
4  
Could you provide further details on this? From how I see it, this information is lacking in credibility. –  Daniel B Jul 18 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.