Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running CentOS 6 x86_64. There is a software RAID 1 being used on the two internal 80GB drives. I got the following e-mail sent to me:

A DegradedArray event had been detected on md device /dev/md1.

Faithfully yours, etc.

P.S. The /proc/mdstat file currently contains the following:

Personalities : [raid1]
md0 : active raid1 sda1[0]
      511988 blocks super 1.0 [2/1] [U_]

md1 : active raid1 sda2[0]
      8190968 blocks super 1.1 [2/1] [U_]
      bitmap: 1/1 pages [4KB], 65536KB chunk

md4 : active raid1 sdc1[0] sdb1[1]
      1953512400 blocks super 1.2 [2/2] [UU]

md3 : active raid1 sdd5[1] sda5[0]
      61224892 blocks super 1.1 [2/2] [UU]
      bitmap: 1/1 pages [4KB], 65536KB chunk

md2 : active raid1 sdd3[1] sda3[0]
      8190968 blocks super 1.1 [2/2] [UU]

unused devices: <none>

The system appears to have booted fine and is working.

The two drives' content did not change at all. I only removed and reinstalled them while I was booted on the CentOS Live DVD.

How do I get the array working again?

share|improve this question
3  
So you removed part of a mirror. Worked on the system (thus changing the contents of the non-removed mirror drive). Then put the old drive back and you are surprised that the contents do not match and that the computers complains about it? –  Hennes Oct 22 '12 at 14:00
    
I didn't change the two drives at all. I only removed them, and re-installed them as I said. I didn't change the contents of them at all. The other devices weren't even powered on, I was running from CentOS DVD-ROM to test them out. Now, do you have something constructive to add for me to fix this? –  Edward Oct 22 '12 at 14:24
    
I read the OP as I removed two drives of a two different RAID sets. Then did stuff with other disks, then put the disks back. With your edits to the OP it now makes more sense. –  Hennes Oct 22 '12 at 15:03
    
Even after the update, it's still confusing. I don't think there's any need to add "UPDATE:" when you can directly edit the post so that it is more clear. –  gparent Oct 22 '12 at 15:49
3  
The same thing Hennes is mentioning. He's entirely right, your question leads one to think that you wrote on the non-removed mirror drive. Quoting Roosevelt won't change that. –  gparent Oct 22 '12 at 15:52
show 3 more comments

1 Answer 1

up vote 6 down vote accepted

When you pulled out the drives from your running system, you broke the mirrors.

Re-add the appropriate partitions to your failed mirrors:

mdadm --manage /dev/md0 --add /dev/sdd1
mdadm --manage /dev/md1 --add /dev/sdd2
share|improve this answer
    
Thanks, MikeyB! –  Edward Oct 22 '12 at 15:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.