Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I put NT Emacs on a usb drive so that I could use it on my University library's Windows machines on days where I can't bring my linux laptop with me. Most of my work involves editing files remotely on a Red Hat server that only allows secure connections (scp/ssh). On my laptop, TRAMP mode has never failed.

I set the default method in the .emacs file to use ssh. However, on the Windows machines I can't get NT Emacs to correctly log in. All of the Windows machines have PuTTY installed, so I have tried setting the tramp default mode to both "ssh" and "plink", but every time I try to remotely edit a file it says "opening FTP connection" and hangs indefinitely. I am assuming that it is hanging because the server is not accepting the (unsecure) FTP connection, even though I told it to use ssh or plink.

Can anyone help me with this?

share|improve this question
    
BTW, my .emacs file includes:(require 'tramp) (setq tramp-default-method "plink") or (setq tramp-default-method "ssh") – Bryan Brown Oct 22 '12 at 18:05

For some reason emacs under windows doesn't try using TRAMP when you use the normal format. You have to explicitly use the tramp format which is: /[ transport / name@site#port ] filename

note that the square brackets are required and remove the spaces.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .