Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Microsoft Outlook as my email client. I can alway receive emails from home or when connected to a different network, but I can only send when connected to the internet from home. If I try to send an email from a public network, or any one that is not my home network, then the emails are not sent but will be sent immediately when I am in range of the home wifi.

From reading I understand that POP3 email servers store received emails, so it seems that I am able to access data from these servers no matter what network I am connected to. But when I send an email, it is sent to an SMTP email server, so it seems that I can only access the SMTP server when I am at home.

So, I am thinking that this is either an authentication issue with the SMTP server, or Outlook is being helpful, by blocking my outgoing emails when connected to an untrusted network.

Settings

  • In Outlook, User Information, Server Information and Logon Information is all filled in.
  • Logon using Secure Password Authentication is not checked
  • In the Outgoing Server tab of the Internet Email Settings, the my outgoing server (SMTP) requires authentication is checked and the radio button for use same settings as my incoming server is selected.

Does anyone think that I may need to select the Logon using username and password in the Outgoing Server tab of Internet Email Settings?

Or is this likely to be an issue with the SMTP email server (perhaps that it only accepts emails from a whitelist of IP addresses)?

Is there anyway I might be able to test this without going out of range of my home network?

Sorry for this being so long. Thanks in advance for your help.

share|improve this question

migrated from stackoverflow.com Oct 22 '12 at 20:00

This question came from our site for professional and enthusiast programmers.

    
What ISP are you using? They generally have setup instructions that describe any available authentication, proper port setup, etc. –  Alan Shutko Oct 22 '12 at 20:03

2 Answers 2

Public locations might well block Port 25 (the default SMTP port) to stop people abusing their network. If you're using an ISP email server it could well block SMTP requests from outside it's IP range.

Two things to try:

  1. Try using a public SMTP server like Yahoo. SMTP doesn't dictate which server an email needs to be sent from, ie you can send a me@mydomain.com from a Yahoo SMTP server.

  2. Try using Port 587 instead of 25 for your SMTP connection. It's a common alternate port for SMTP.

To test out the connection to an SMTP server from the command line you can use telnet:

telnet smtp.mail.yahoo.com 25

Hopefully you'll see something like this:

C:\>telnet smtp.mail.yahoo.com 25
Connecting To smtp.mail.yahoo.com...

220 smtp123.mail.ird.yahoo.com ESMTP
share|improve this answer

Have you got a program to send the mail? I.e Sendmail/postfix on a linux server or Microsoft Exchange Server for windows based servers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.