Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting terrible frame rates while trying to stream videos on YouTube, particularly HD and/or fullscreen ones, while using Firefox on Win8. However, once the video is fully buffered there does not seem to be a problem.

This problem doesn't seem to happen when using IE, so I am suspicious that it has do with Microsoft's security features that apparently limit the functionality of other browsers (if those rumors that I heard are true).

I have already disabled flash's hardware acceleration and running Firefox with dedicated GPU doesn't seem to change anything.

Anyone else having similar issues or know how to fix it?

Hardware: ASUS u43jc OS: Win-8 64bit

share|improve this question
    
Upgrade your network drivers. –  Tom Wijsman Oct 22 '12 at 22:04
1  
Your suspicious are not accurate. This likely has to do a simply performance problem with Firefox. There are no security features within Windows 8 that would explain your problem. –  Ramhound Oct 22 '12 at 22:07
1  
Your laptop has dual graphics - intel and nvidia. Which of these are running while you are watching videos, and what drivers have you installed? –  Paul Oct 22 '12 at 22:30
    
It seems to be network related because it was not happening on campus earlier today despite there being no significant speed or ping difference. Upgrading network drivers seems to be an obvious choice, but Intel seems to not have released drivers for Win8 yet. I'm currently using Microsoft's latest drivers. Will Intel's Win7 drivers be compatible? I'm using a Centrino Advanced-N 6230 –  WeymannD Oct 23 '12 at 4:33
    
@WeymannD: In my experience, some Windows 7 drivers work in Windows 8, but not everything. It totally varies on the type of hardware, drivers, quality of both, and age of the hardware (indicating how current the drivers are). –  Mufasa Oct 27 '12 at 19:38

1 Answer 1

Linux users will frequently note that this happens when graphics acceleration is not supported. Maybe this will work for you.

Try to force it via the about:config

and toggling the followin options

gfx.direct2d.force-enabled = true
layers.acceleration.force-enabled = true

If this doesn't work then there is something wrong with how your graphics card interacts with the system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.