Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded my Vista Ultimate to Windows 7 Ultimate (RTM) and after that it doesn't wake up from sleep. When I power it on it turns on but nothing happens, but if I press the reset button it boots and then wakes up, I mean, it doesn't reboot Win 7, it actually wakes up.

Anyone have any clue about such a weird behaviour?

It always worked fine on Vista. I have a GForce 8600 with the latest drivers.

share|improve this question
    
If it is indeed a bug due to a video driver, I wouldn't expect nVidia to fix the issue for a while. They have a terrible track record of not fixing critical bugs after the release of a new OS until months after release. –  Will Eddins Sep 30 '09 at 18:17

3 Answers 3

up vote 7 down vote accepted

Ideas for resolving not coming out of sleep:

  1. Disconnect any and all unnecessary devices from your PC. Pare it down to the absolute minimum : unplug anything you can disconnect, turn off and unplug the computer from the mains for a few minutes, then reboot.
  2. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S3" etc.
  3. Ensure "Allow this device to wake computer" is checked in in "Device Manager/$device$/ Properties/Power Management", where $device$ stands for keyboard and mouse.
  4. Turn off Hybrid sleep, see explanation here (for Vista, but is the same)
  5. The hibernation file is sometimes disabled by disk cleaning, to restore do in cmd run as administrator "powercfg -h on".

You can use the following command to troubleshoot sleep problems and return a detailed report:

powercfg -ENERGY

image

share|improve this answer
    
Hybrid sleep is probably what makes your computer wake up instead of rebooting when you press reset. If turning hybrid sleep off does not solve your problem, I'd recommend to leave it on. –  djeidot Oct 1 '09 at 12:35
    
Should have mentioned that any above manipulation should be undone if it doesn't help. –  harrymc Oct 1 '09 at 13:40
1  
I tried 3, 4 and 5, nothing changed. So a did #2, switching "S1 and S3" to just "S1" and it wakes up as it should. Thanks. –  Eder Gusatto Oct 3 '09 at 0:30

Its part Windows 7 and part driver issue (Vista drivers re-certified as Windows 7 when they should rewrite them for some devices). If you install windows vista then your sleep mode will work perfectly fine. On the other hand some other computers that uses Windows 7 (32 and 64) sleeps fine in S1 and S3 state like my Laptop Gateway. So it really depends, I recommend you want for a update patch or vendor updated Windows 7 drivers after you let them know of the situation.

share|improve this answer

I have been having the exact same problem with my AV Server/PVR machine (Intel MB) and spent almost a week (on & off) trying to solve it, so here is what worked for me...

  1. Enter the BIOS and set power management to S1 - the Intel Bios warns about using S3 as some programs or device drivers do not work when set to S3 of higher.

  2. In the BIOS - disable Wake up on LAN - I have been told that routers perform polling to see what is connected if they are in DHCP mode - this wakes the computer

    • I do not need to have LAN activity wake up this particular machine - so it is not an issue
    • seems my wireless router does not have this effect on the machine, but my wired router causes problems

Once I made these changes everything worked fine - even better than fine - since my ATSC tuner card from HAUPPAUGE wakes up the machine to record programs even from Hibernate mode, but then there is no keyboard wake-up - you gotta get out of the lazy-Boy and press the power button.

Sleep also works as required and allows for keyboard wake-up, but the fan stays on (not sure why)

Hope this helps

share|improve this answer
    
The S1 mode did it for me. Thanks! –  genpfault Nov 9 '10 at 5:30

protected by Diago Jan 10 '11 at 14:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.