Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This happens all the time. It screws up my formatting... If I make a tab 2 times (8 spaces) it will turn to one tab (4 spaces) and 1 tab turns to 2 spaces etc. Does anyone know how to fix this?

share|improve this question
    
Are you using the latest release of Notepad++? As of today, they are on v6.2. Any plug-ins that you have added? – techturtle Oct 22 '12 at 21:39
    
No plugins, and i'm currently running on v6.2 – Vincent Oct 22 '12 at 22:05

Perhaps your tab size is set to 2 spaces. Click on menu "settings" then "Preferences...", then switch to tab "Language menu/Tab settings", check the value of "Tab size" on the right bottom

share|improve this answer
    
It is not, when i tab it creates 4 spaces, but when i re=open the file the tabs turn into 2 spaces – Vincent Oct 23 '12 at 19:23

Make sure you don't have the 'Replace by space' checkbox set next to the 'Tab Settings' in the Preferences->Language Menu/Tab settings.

share|improve this answer
    
I need the tabs to be spaces because of the formatting i am doing. It is set to 4 spaces – Vincent Oct 23 '12 at 19:26
    
If you create a brand new file, tab twice add some text "Hi there this is a test", and save it as myfile.txt. When you re-open it has just four spaces? I've just tried exactly that without any problems. – snowdude Oct 23 '12 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .