Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently switched from Windows to Linux (elementary OS), and installed Notepad++ with Wine.

It works fine, but looks like Windows 95.

Screenshot

I tried setting registry settings to make the fonts look better, and everything from this thread.

I also tried compiling Wine with this patch applied.

Nothing makes a difference to the font rendering.

How can I enable font hinting or anti-aliasing in Wine?

share|improve this question
    
What version of wine? –  Michael Hampton Oct 23 '12 at 2:20
    
@MichaelHampton I'm using Wine version 1.5.15. –  uınbɐɥs Oct 23 '12 at 2:23
    
Try using a stable (1.4.x) version instead? –  Michael Hampton Oct 23 '12 at 2:24
    
@MichaelHampton From what I've heard, font smoothing stopped working in v1.1.x, but I will try 1.4. –  uınbɐɥs Oct 23 '12 at 2:28
    
@MichaelHampton I looked at the screenshot in the Software Center (v1.4), and the font is aliased / not smoothed. –  uınbɐɥs Oct 23 '12 at 2:37

1 Answer 1

up vote 2 down vote accepted

It turned out to be easier than I thought: font substitution.

Smooth fonts in Notepad++/Wine


Here's how to make the fonts look better:

  1. Navigate to HKEY_CURRENT_USER\Software\Wine\Fonts\Replacements in the Wine registry editor (wine regedit).
  2. Create a new string value called Segoe UI, and set its value to Droid Sans (or any other sans-serif font name).
  3. Naviagte to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\FontSubstitutes.
  4. Create a new string called MS Shell Dlg and set its value to a sans-serif font (I used Droid Sans again). Create another string called MS Shell Dlg 2 and do the same. [source]
  5. Close the registry editor and run wineboot to restart Wine.

Great! Smooth fonts!

But: the monospace font in Notepad++ is still jagged.

The fix for that is quite easy, too:

  1. Open the Style Configurator (Settings -> Style Configurator).
  2. Choose the font and font size that you want, then check 'Enable global font' and 'Enable global font size' to activate the settings. I chose Droid Sans Mono as the font.

I hope that this will help someone else too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.