Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My WiFi connection randomly drops with the following message in event log:

The browser has forced an election on network \Device\NetBT_Tcpip_{F7CCEBC3-DDA9-4502-AF3D-1F016D5D6B07} because a master browser was stopped.

Troubleshooting via tray icon connects the WiFi. This happens 2-3 times a day.

Update 1: Disabling WinHTTP Web Proxy service has no effect.
Hardware: Atheros AR9002WB-1 NG Wireless Network Adapter

share|improve this question
1  
This is for windows 7 but might be related: sevenforums.com/network-sharing/… –  George Duckett Oct 23 '12 at 8:19
    
@GeorgeDuckett Disabled WinHTTP Web Proxy service. Startup was set to mannual but this service was running. Will it cause any any problems? –  Serious Oct 23 '12 at 8:29
    
Did you try to run Troubleshoot utility. If yes then what error you get? –  avirk Oct 23 '12 at 15:06
    
Troubleshooting fixes the problem temporarily but WiFi drops again after some time. –  Serious Oct 24 '12 at 4:25
    
what is your wifi hardware? –  SnippetSpace Oct 25 '12 at 13:13

3 Answers 3

If you are using the drivers provided by your pc vendor try to uninstall those and let windows manage your card. This also works the other way around.

If this doesn't fix it there is another problem.

Seems that there are a lot of driver problems for this card:

You may want to try this driver: http://drivers.softpedia.com/get/NETWORK-CARD/Atheros/Atheros-AR9002WB-1NG-WLAN-Driver-100067-for-Windows-8.shtml although it may in theory not be safe. Atheros (qualcom) does not provide any drivers on its website...

Another potential source of drivers. Try the latest one if the one above does not work: http://www.atheros.cz/atheros-wireless-download.php?chipset=31&system=5

share|improve this answer

Though I can't see how (and the tech who did it couldn't explain it), a firmware update on my Dell seriously helped this problem. It's worth a shot.

share|improve this answer

Spent half the day trying to figure this out on a Toshiba Windows 8 Laptop... WiFi kept dropping every few minutes then would reconnect... after trying every setting I could think of with no luck I stumbled on to a SOLUTION. I went to Control Panel>Device Manager>Network Adapters>Wireless LAN>Properties>Advanced>Bandwidth>the default was set to "20_40MHz" I set it to "20MHz Only". Problem SOLVED!! The WiFi Connection has been working flawlessly ever since.

share|improve this answer
    
That is not the OP's problem, though; the OP is having issues with the master browser election, which is completely unrelated to the bandwidth of your Wifi. –  BenjiWiebe Feb 15 '13 at 2:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.