Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


  1. yesterday I still could access my domain in my browser (Firefox), today I can't anymore. I tried both domain name and IP address. This is not a browser problem: IE can't either, and Outlook can't get e-mails from the domain.
  2. It's not a PC problem either: I tried on another PC but no joy
  3. It's not a server problem either: reports the site as reachable
  4. It seems like it's not a router problem either: I can access any other site I want, just not my domain. I checked the router's setting to see if it blocked my domain, but I couldn't find anything suspect. (Not surprisingly: I did not make any changes to its settings since I installed it a month ago).

Yet, the router remains the first suspect; a different computer connected via the same router has the same problem. Not: problem persists when router is bypassed.

I'm completely puzzled, but that usually means the solution is quite simple, so let's hear it! :-)

I tried some of Choy and Chloe's advice (thanks to both of you), and this is the result:

  • Choy's idea of bypassing the router was a good one. It's not the router; when I connect directly to my modem the problem is still there.
  • I had already checked hosts, it's clean
  • ping doesn't return any package (100% lost)
  • changed the DNS in my router to OpenDNS: no joy :-(
  • I tried tracert:

Tracing route to []  
over a maximum of 10 hops:   

  1     1 ms     3 ms     1 ms   
  2     8 ms     9 ms     8 ms []   
  3     *        9 ms    11 ms []   
  4    13 ms    11 ms    11 ms []   
  5    13 ms    11 ms    11 ms []   
  6     *        *        *     Request timed out.  
  7     *        *        *     Request timed out.  
  8     *        *        *     Request timed out.  
  9     *        *        *     Request timed out.  
 10     *        *        *     Request timed out.  

Does this mean Telenet (my ISP) blocks my domain?

  • I also tried via my mobile phone on 3G, and that doesn't work either. Caveat: my phone's operator is that same Telenet.

I welcome new ideas!

share|improve this question
Did you trying pinging the site? What about by-passing the router completely and hooking directly into your internet connection? That would at least rule out the router. – Choy Oct 23 '12 at 14:59
is it a shared server? if it isn't you could use the IP address to connect. – Journeyman Geek Oct 24 '12 at 1:05
@JourneymanGeek the OP said that he tried both domain and IP. – Choy Oct 24 '12 at 1:08

Things to try:

  1. Command prompt: nslookup
  2. Load your on your mobile phone using 3G or 4G, not your network.
  3. Check for entries in \windows\system32\drivers\etc\hosts
  4. Use your routers Admin > Troubleshooting page to do a ping test for your domain.
  5. ping, make sure the IP matches #1.
  6. Unplug & re-plug your router (Linksys sucks).
  7. Check Control Panel > Network Connections > Network Name > Properties > TCP/IP > Properties > DNS = Obtain automatically from DHCP.
share|improve this answer

IMO the trace route points at Telenet as the culprit: the request seems to die in one of their servers. I asked a couple of friends to try and access the site, and none of the Telenet customers could reach it.

Contacted Telenet helpdesk twice. The first person wasn't helpful at all, so I called again later and got somebody else on the line. She admitted that it was possible that Telenet blocked the domain, but she could not check that from her desk, and will report back later.

Which leaves the question why for Pete's sake Telenet would do this. I'm not that paranoid to think they would purposefully block just my domain. The only explanation I can think of is that one of the domains hosted by my webhost contains unlawful content (*), and that instead of blocking that domain they blocked the complete SLD.

(*) Several Belgian ISPs blocked all The Pirate Bay's domains sometime this summer, so maybe yesterday they found out about a TPB mirror (or other illegal content) under the same SLD as my domain.

share|improve this answer

Consider also that your web host may be the one blocking your ISP for any of a number of reasons including Bogon filtering. I would check to make sure that they aren't the ones at fault.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .