Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my user folder on a another (internal) disk. Now I have to repair permissions and don’t know how to do it. I suppose to do this via the terminal would be the proper way.

If there is any tool, app or way to do this please enlighten me.

EDIT:

I’ve to repair permissions because I can’t make change in the user, I can create folders and stuff like usual but if I try to change something in the system preferences, f.eg. background image, secondary mouseclick or mobileme sync the system won’t save the changes. I’ve added some details to my original question what I've tried so far.

HERE is a screenshot of my information dialog which visualizes how my permissions are set up. (Sorry - as a new user I couldn’t post an image, so the link will have to do.)

Since Steve Folly suggested to change the permissions on the ownership I tried that and typed this into the terminal:

sudo chown -R patte:patte /Volumes/Lagerhalle\ 1/patte

But sadly got Invalid argument back in return. Desperadly I also tried some variations:

sudo chown -R username:patte /Volumes/Lagerhalle\ 1/patte
sudo chown -R admin:admin /Volumes/Lagerhalle\ 1/patte

Same response from terminal: Invalid argument.

I also did the other suggestion / the following step:

sudo chmod -R 755 /Volumes/Lagerhalle\ 1/patte

It went alright but in two little Dropbox folders it told me Operation not permitted - so these 2 folder are no big deal.

sidenote: you can see that the drive is named "Lagerhalle 1" since I recently had to backup and rebuild the drive. Since the clone was also named "Lagerhalle" the rebuild partition was automatically named "Lagerhalle 1". I tried to rename the partition to the name without the "_1" by erasing the backup volume and renaming it via terminal but the "_1" still remained. But that's another story….

PS: What I was wondering about is if it's correct that there is no admin on my 2nd HD. I had it all working once, but couldn’t recall if it was always that way (that the admin is only on the root volume/system volume).

share|improve this question
    
The 'Invalid argument' error from chown would imply user 'patte' does not exist on your system. The user folder may well be there, but the user account itself does not exist - check the Accounts System Preferences. –  Steve Folly Sep 30 '09 at 21:36
    
That’s impossible. I manually log into this account and I have proof it exists :) --> tiny.cc/q2JBl -- I could delete the User "patte" and create a new one with the exact same name and point this account to the user folder on the 2nd HD. But I doubt that this would change the situation. –  pattulus Sep 30 '09 at 22:35

2 Answers 2

I have to ask - how do you know you have to repair permissions?

Disk Utility's 'Repair Permissions' feature is for repairing permissions on installed applications and system features typically on the start up disk. As you seem to have realised, it doesn't touch user folders.

Do you have file ownership problems - i.e. files in the user's folders are not owned by them? Or permission problems - i.e. other users can read too many files?

chmod and chown are probably your best bet from the command line.

$ sudo chown -R username:username /path/to/username

Once you've set the ownership correctly, your should be able to chmod your own files:

$ chmod -R 755 /path/to/username
share|improve this answer
    
Thank you very much for your help so far. I couldn’t manage to perform your steps completely and explained this in the original question/1st post which I edited. Hopefully you can help me on this one. –  pattulus Sep 30 '09 at 21:19
up vote 0 down vote accepted

Solution

This is what helped me out:

$ sudo chmod -R ug+rwX /path-to-username/shortname
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.