Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Debian 64bit from a Debian live image using YUMI on my usb drive to an Inspiron 6400. I am missing firmware for the Broadcom BCM4401-B0 100Base-TX.

I have tried configuring it myself to no avail. I downloaded the drivers, transferred them to the laptop, and it wouldn't run the install file because none of the networking directories seemed to exist.

Does anybody have experience with this, or could anybody nudge me in the right direction?

share|improve this question
    
Wow, the chances that you happen to reply at this moment(like a month later) when I'm having this exact problem are pretty slim. It's the broadcom 440x series. The Broadcom Corporation BCM4401-B0 100Base-TX to be exact. I just can't connect to the internet(even by wireless at this point). What should I do?(The b43 drivers work completely, I'm just having a localized network problem now). –  Scriptonaut Nov 16 '12 at 8:56
    
I just now made a discovery, I can connect via IP, however can't do the same with domain names. I pinged google on the current machine I'm using, took the ip(74.125.224.70), and my browser connected to it just fine. –  Scriptonaut Nov 16 '12 at 9:02
    
It's totally my DNS, what should I do? Can I set the dns to something else if this refuses to work? –  Scriptonaut Nov 16 '12 at 9:03
    
As a workaround for your current problem (not the one in the question) Set DNS to 8.8.8.8 (or any other publicly usable DNS server). - To get the current question answered, add detail to it. Just 'I can't connect to the Internet' will result in few answers. But 'I have this specific NIC. Drivers fail to load. I tried $this and $this2' are more likely to get you help. –  Hennes Nov 16 '12 at 9:07
    
Holy fucking hell you fixed my problem. I just edited my /etc/resolv.conf file to 8.8.8.8. It worked. How can I repay you? Can I give you points or something? You have no idea how thankful I am to you right now. –  Scriptonaut Nov 16 '12 at 9:21
add comment

1 Answer

up vote 0 down vote accepted

Apparently installing some WLAN drivers blacklists some Ethernet drivers.

Open the file /etc/modprobe.d/broadcom-sta-common.conf and comment out the line blacklisting the Ethernet adapter (which was b44 by the way).

The file now looks like this:

# wl module from Broadcom conflicts with ssb  
# We must blacklist the following modules:  
#blacklist b44      
blacklist b43legacy  
blacklist b43  
blacklist ssb  
install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS  

(Notice the added # sign in front of blacklist b44)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.