Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google Apps installed and I have tried to set up Outlook 2007 to send messages via SMTP.

I followed the guide, selecting what I believe are all the correct settings. Yes, I am using POP for incoming, that is intentional but I don't believe it should affect outgoing messages.

When I log into gmail (google apps) for my company, I can send a message that has an 8MB attachment (pdf file, not zipped or anything) and it sends fine. However, when I send the same message in Outlook with that same 8mb attachment it fails.

Why am I unable to send an attachment with Outlook via SMTP that I am able to send via Gmail / Google Apps?

The message headers are (some info omitted for privacy):

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient
domain. We recommend contacting the other email provider for further
information about the cause of this error. The error that the other server
returned was: 552 552 #5.3.4 message size exceeds limit (state 17).

----- Original message -----

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=company.com; s=google;
        h=from:to:cc:references:in-reply-to:subject:date:message-id
         :mime-version:content-type:x-mailer:thread-index:content-language;
        bh=7d4i/Cbt0v0sY3zt5lN6y5CdvxjbRmTBG4AuBuMxtF4=;
        b=IJwwxuIEdg1E4zXuGjeDod+1w3RYBBCNzSsqpuX77ih36HSiq++s3ZCQXPeU9CIZVg

K8JPJQu9xjivYYjrRaYwyeowLIu0GIdR2h4kKEkFM/GNC2RFF3VwVgj+gvi5eqVZIuWn
         osT5/VEm10IED6B54NPOtGMgFTci6a57zzVKE=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=20120113;
        h=from:to:cc:references:in-reply-to:subject:date:message-id
         :mime-version:content-type:x-mailer:thread-index:content-language
         :x-gm-message-state;
        bh=7d4i/Cbt0v0sY3zt5lN6y5CdvxjbRmTBG4AuBuMxtF4=;
        b=LjTecjok5K71Bymp6tZqAL2XCz03hWROV1mTK8Vf2AeEJwtel9ACu9kE5jW5iJqckb

upYKPzoqYLBwAPOzMb9asWoTAZPzC7LMG65eDUc2/ZEvGqXrZs3ziUxwhF4t169yRVuy

/6nm/aAt5uPMLPdobxGTJ8ahOIku1Z3gW+OcvZ6ERk1Av/bvuln09vcnyJIrHGh7eK8n

cbGVxmK0aecgSPgIj2NALbHkyuxwj+LEBRV6uiz3THDjxAiNfsO5UFjV59sD+lVSBT3z

ThOGE8WEXRnKHuP3FuKXyeUxKBZ2CxpWJpvDuS9EsFkln7zkISYEsRA0nUA6GSGi2Z/n
         8YUg==
Received: by 10.60.169.197 with SMTP id ag5mr12254920oec.137.1351036287413;
        Tue, 23 Oct 2012 16:51:27 -0700 (PDT)
References:
Date: Tue, 23 Oct 2012 19:51:16 -0400
Message-ID: <003a01cdb179$4bb2ca60$e3185f20$@com>
MIME-Version: 1.0
Content-Type: multipart/related;
        boundary="----=_NextPart_000_003B_01CDB157.C4A12A60"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index:
Ac2xVCHGxoC7DDOkQBK3JSXowHb0EQAEB7agAAA/YKAAAIGcQAAAngfQAABAAPAAAFe7gAAAadvw
AALgvLA=
Content-Language: en-us
X-Gm-Message-State:
ALoCoQniMq7Fnh+NlfoWjTJPvKWbkhEaftSaFo9ZVvtRpWufTmhlRDx1a9Jf+wmYcbRh896gygNr

The company I am sending email to is a company that uses Google Apps for Teams. This is their apps admin login. Should I be worried about that message?

Picture 4.png

My Settings

On the Google apps side I have set my SPF record and set / verified my DKIM key. Here are my outlook settings:

Picture 1.png

Picture 2.png

Picture 3.png

Why am I unable to send an attachment with Outlook via SMTP that I am able to send via Gmail / Google Apps?

update Per request via comments, here is the setting for outbound relay in Google Apps:

Picture.png

share|improve this question
    
Just to clarify: you're sending the message with the same 8 mb content to the same recipient, once via Outlook configured to use Google Apps, and the second time via Gmail frontend of Google Apps. Am I right? –  laika Oct 30 '12 at 8:06
    
@skrco - yes that's right. that's why it's perplexing. –  cwd Oct 30 '12 at 14:09
    
One more question then... What is the value of this checkbox Google Apps Cpanel -> Settings -> Email -> Outbound relay -> Allow users to send mail through an external SMTP when configuring a "from" address hosted outside your email domains? –  laika Oct 30 '12 at 15:52
    
btw whois is saying that they no longer use google apps for email delivery –  laika Oct 30 '12 at 16:05
    
@skrco - that is the receiving domain. also updated the question with a screenshot - it was checked already. thanks for working hard on this one. –  cwd Oct 30 '12 at 21:47

2 Answers 2

up vote 2 down vote accepted
+50

My best guess would be that Outlook is using the Quoted-Printable encoding for your attachment, which would make it much larger than the original.

You may want to try and follow the directions in KB 278134 and edit the InternetMailTextEncoding key in the HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Mail registry subtree. If you assign a DWORD value of 2 (use Base64) or 3 (don't encode, send 8-bit attachments) to it, and that solves the problem, then you'd have found the culprit.

share|improve this answer
    
This could well be the culprit - the key indicator is that it's the recipient domain that's rejecting the message, not Google itself. So the issue isn't that you can't send it, but that it is being rejected by the recipient. –  PJC Nov 5 '12 at 12:59
    
seems to have fixed it (fingers crossed) –  cwd Nov 19 '12 at 20:40

My suggestion would be this MS article:

http://support.microsoft.com/kb/322679

This article describes the different kinds of limits that you can set on message size in Microsoft Exchange 2000 Server and in Microsoft Exchange Server 2003. It also explains how you can set these limits.

Note If you have configured a size limit on either the Send or Receive sizes in global settings, the More Restrictive limit applies to both incoming and outgoing e-mail messages.

or these hints here: http://social.technet.microsoft.com/Forums/nl/exchange2010/thread/0d5167bf-1722-441a-b636-87d639756a3b

Hope these will help you.

share|improve this answer
    
it's not an exchange server. It is just Outlook sending via google apps' smtp –  cwd Oct 31 '12 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.