Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From Teamviewer on XP (remote) to Teamviewer on Fedora 17 with XP or Win7 VMs, can't pass any keys except alphanumerics ([a-zA-Z0-9]) to Windows. This has persisted thru 3 Fedora releases and 3 or 4 Teamviewer and VBox updates. No problems with Linux apps and no problems if using the host keyboard with Windows.

To clarify, I can't pass any special characters (like a period) from any device (PC, Android, iOS) to any Windows instance.

share|improve this question
    
What exactly is your setup here? You mention Fedora 17 with XP under VirtualBox - is this a different machine running Fedora as the host OS and XP virtualized? –  Henning Klevjer Oct 24 '12 at 5:45
    
No, it's just one machine - Linux host, Windows guest. Teamviewer is running on the host. I don't want to also install it on the guest. –  SteveC Oct 24 '12 at 17:45
    
I've got the exact same problem. Debian Wheezy connecting to Ubuntu 13.04. Spotted this report from 2010 (Mac to Linux), same issue: forums.overclockers.co.uk/showthread.php?t=18206524 Have raised a ticket with teamviewer.com, here's hoping. –  thomanski Mar 4 at 23:06
    
Teamviewer support got back to me stating that this is a known issue that they are working to fix. –  thomanski Mar 13 at 22:43

1 Answer 1

Update the keyboard driver on your Windows guest.

If there aren't any updates for your keyboard driver (or the update simply doesn't resolve anything), try installing the USB 2.0 pack into VirtualBox by following the steps below:

Before you start, make sure the guest isn't running and that you have a USB keyboard.

  1. Start VirtualBox, select the Windows XP guest in the left pane, and click Settings.
  2. In the Windows XP - Settings dialogue, select USB in the left pane.
  3. Tick Enable USB Controller and Enable USB 2.0 (EHCI) Controller.
  4. After you tick the second box, a dialogue should appear. Click the button that says something like "Install VirtualBox Pack" or something similar (I forgot).
  5. Click the download link for the VirtualBox Extension Pack.
  6. After you download the file, open it. VirtualBox should give a dialogue asking if you want to install the pack. Click the button that says "Yes" or something similar.
  7. Tick Enable USB 2.0 (EHCI) Controller again.
  8. Hit Alt+Insert and select your keyboard from the menu that pops up.
  9. Lastly, you start the Windows guest and tell me if this solution works.

Note: I never had a problem with the keyboard on my virtual machine, so you will have to bear with me.

share|improve this answer
    
Thanks, but none of that helps. The ExtPack was installed, the Guest Additions were installed, and there are no items displayed when I try to add a new filter for the selected device. It's a PS/2 keyboard and Windows' sysinfo shows the same driver used by my other XP machine. –  SteveC Oct 29 '12 at 0:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.