Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Pretty short story, I just wondered what was at play here. I have a windows 7 box with NTFS on it. I don't have any application that can open/read/anything .dmg on that PC. I have a 7GB CD image in .DMG format. I tried to copy it to my external and it was moving along at about 1-3 Mb/sec (according to the advanced file copy dialog.) I stopped the copy and changed the extension from .DMG to .JPG and copied the file. It was moving along at 30-50 Mb/sec. The target and source are both NTFS.

What is at play here?

Also, I'm not concerned about my low transfer speeds as a whole, I was using an old external hard drive over USB 1.1, but I'm more wondering why transferring a .JPG is over an order of magnitude faster.

I also tried this multiple times. Every time, the speeds were roughly the same.

share|improve this question
3  
Are you sure you didn't just see the effect of parts of the file being still in cache? –  Joey Sep 30 '09 at 19:43
    
Aye, I fully copied the 7GB file in .jpg twice and waited 20 minutes for the .dmg twice. To note, I did the .jpg transfer first. –  Thebigcheeze Oct 1 '09 at 0:27
    
7GB, that's a heck of a CD image (given that a DVD won't even hold that much). Do you mean 700MB, or is it actually a virtual disk image? –  kmarsh Oct 1 '09 at 12:52
    
It's a dual layer DVD image, so i believe 10.8 is the max for dual layer. –  Thebigcheeze Oct 2 '09 at 21:06

4 Answers 4

Do you have Anti-virus configured to scan dmg file but exclude jpg files?

share|improve this answer
    
+1: It's worth noting that DMG would likely be scanned simply because the AV program doesn't know what it is, and wouldn't scan JPG because it does know what it is. Also, it'd be worth trying the copy as DMG with your AV program disabled. –  EvilChookie Sep 30 '09 at 22:48
1  
EvilChookie, A good AV program wouldn't trust file extension alone and would check what it is anyway. –  Bender Sep 30 '09 at 23:13
    
I'm using Avast free edition. I checked the whitelist and the only things whitelisted are .ini, .txt, and C:\pagefile.sys, and it's set to check all files when I open them (copy involves an open operaiton, right?) –  Thebigcheeze Oct 1 '09 at 0:28
    
@Thebigcheeze - nope, copy doesn't necessarily involve opening the file, a byte by byte operation would work just as well. In fact better as the system doing the copying doesn't have to know anything about the file being copied. –  ChrisF Oct 1 '09 at 11:57
    
I think you are getting into semantics if you say copy doesn't open the file. As far as the av package is concerned, the file will be opened (by the operating system as opposed to an application) and this will trigger the scan. –  sgmoore Oct 1 '09 at 12:34

Start Task Manager, then launch Resource Monitor. Now copy the .dmg file again while watching the CPU monitor (click on the CPU column to sort descending). What programs are taking up CPU while copying?

share|improve this answer

USB 1.1 provides speeds up to 12 Mbits/sec (1.5 Mbytes/sec). So the file must have been cached.

share|improve this answer

My Second suggestion. (Apologies if this is bad form).

Could this be something to do with 'Remote Differential Compression' and the fact that the file/data may already exist on the destination.

If you temporarily disable this feature, do jpg's transfer at the same rate as other files?

Easy way is to do find this option is run OptionalFeatures from the start menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.