Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I File>Email page location in Google Chrome for Mac it opens a new email in OSX Mail.

It always used to open a new gmail.

How do I make it do this without using Google Notifier?

share|improve this question
up vote 1 down vote accepted

Normally, opening Gmail in a recent version of Google Chrome should prompt you to set it as the default mail handler. What you can do is try to open the JavaScript console via J, then paste the following:


Then press . Chrome should ask you to confirm the setting.

To check whether it succeeded, you can also use RCDefaultApp. Download the .dmg file, double-click on the .prefPane file inside, and install the preference pane. Now under System Preferences, you can see Default Apps at the bottom. Make sure that for Email, and the mailto URL scheme, Chrome is set:

share|improve this answer
the console method comes back with underfined – TheLearner Oct 24 '12 at 10:49
It does for me as well, but except for that, does it work or not? – slhck Oct 24 '12 at 10:50
unfortunately not – TheLearner Oct 24 '12 at 10:53
Which version of Chrome are you using? What happens when you run the ad hoc test here? What is in your settings when you visit chrome://settings/handlers? Can you try clearing existing handlers here and adding them again once you're in Gmail? See Chrome help for more. – slhck Oct 24 '12 at 12:49
Yes, but often, this is a problem with your profile rather than Chrome itself. When you open Gmail, does it show a "handler sign" in the URL bar on the right? – slhck Oct 24 '12 at 13:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.