Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This usually happens when in Remote Desktop.enter image description here

As seen in the screenshot I've got some applications opened. A particular application (e.g explorer) is behind so I click on the taskbar icon (it's the third from the left). Instead of it popuping up (restore) it simply flashes gray and blue, exactly as it is shown on the screenshot.

I then have to minimize everything else to find it open.

Why does this happen and how can I solve this?

Link to high res image: http://i.stack.imgur.com/I3haP.png

share|improve this question

1 Answer 1

I have had the same problem many times in RDP. The following applies to RDP from a local PC running Windows7 to a remote PC running XP. Today I tried to debug it and found out two possible issues and solutions: printers and clipboard.

1 - Printers

From other web sites I got the idea of checking the system log on the remote PC (Computer Management -> System Tools -> Event Viewer -> System) and I found many errors and warnings, some related to printers, such as:

  • Error (TermDD): The RDP protocol component X.224 detected an error in the protocol stream and has disconnected the client.
  • Error (TermServDevices): Driver Send To Microsoft OneNote 2010 Driver required for printer Send To OneNote 2010 is unknown.
  • Warning (Printer): Printer Adobe PDF (from [the-PC-I-RDP-from]) is pending deletion.
  • Warning (Printer): Printer Microsoft XPS Document Writer (from [the-PC-I-RDP-from]) is pending deletion.

So I decided to change the RDP settings and disable the forwarding of local printers (RDP -> Options -> Local Resources -> Local devices and resources => untick "Printers"). My RDP initially seemed to work much better after this.

2 - Clipboard

Even after disabling printers, the same problem with frozen applications reappeared (in particular: one IE window stopped responding). I checked in task manager that rdpclip.exe was often at the top of the CPU (even if CPU was very small, only 1%). I then killed rdpclip.exe, and magically my remote IE became responsive again. So I suspect rdpclip is also responsible here.

Note that you have the option to disable the clipboard just like you can disable printers (RDP -> Options -> Local Resources -> Local devices and resources => untick "Clipboard"). But I like to have it enabled, so this does not work for me. You can try killing rdpclip.exe and then restarting it (on the remote PC), this was enough for me to make the IE responsive but then I was unable to copy/paste between the local/remote PCs. Disconnecting from the RDP session and reconnecting was the only solution I found to be able to work normally again. Maybe things would work better for RDP to a Windows7 PC, the rdpclip version is different (5.1 on XP, 6.1 on 7).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.