Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to trancode a video with vlc using the MPEG-4 codec and a video bit rate, I get the following error :

Either both buffer size and max rate or neither must be specified

Here is the command line I used :

vlc -vvv myvideo.m2ts --sout-ffmpeg-strict=-2 --sout '#transcode{vcodec=mp4v,vb=2000,acodec=mp4a,ab=96}:standard{access=file,mux=mp4,dst=/path/file.mp4}'

It seems that I can't specify a video bit rate with the MPEG-4 codec. (If I remove the vb option, it works).
So how can I specify a video bit rate with the MPEG-4 codec ?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.