Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I deleted the device path by running the command: echo 1 > /sys/block/sda/device/delete on Redhat Linux. Since it was the only path, I no longer have connectivity to that machine. I am able to ping it, not able to ssh to it.

How can I add the device path back? I found a link on how to add a new path. But I am not sure how to run those commands since I have no access to the machine. Do I have to physically reboot it?

share|improve this question
in ssh what error you are getting? – max Oct 24 '12 at 11:15
@max ssh error: Read from socket failed: Connection reset by peer – P.P. Oct 24 '12 at 11:17
by running this command echo 1 > /sys/block/sda/device/delete you disconnected the disk. ya you have to physically reboot, i think your system got hang i think. – max Oct 24 '12 at 11:50
You'll need to reboot it. ICMP isn't really going to help you here, you need a shell. – Xyon Oct 24 '12 at 11:53
just reboot the system this is the solution. – max Oct 24 '12 at 11:55
up vote 1 down vote accepted

I am not sure what this command did

I think it will disconnect the device means sda

I tried the same thing, and i also got the same error

[max@localhost ~]$ ssh test@

Read from socket failed: Connection reset by peer

It means the connection was forcibly closed by a remote host due to some reason.

After that I rebooted the system, now it's working fine.

I have no access to the machine for this i don't have any solution.

share|improve this answer
yea, I was almost sure that I had to reboot the system as I can't do run else to fix if I can't ssh to it. Just wanted to know if anyone has any other idea. Thanks for reproducing it on your machine. – P.P. Oct 24 '12 at 12:10
@KingsIndian I learned a new thing today because of you... thanks – max Oct 24 '12 at 12:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.