Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So in using Windows 8, I've discovered that the administrative shares are disabled. There seems to be no easy way to get them re-enabled.

Is anyone aware of a work around, or solution?

I did not have this issue with Windows 7 After disabling UAC. However in Windows 8 this still doesn't work.

This is all I could find, however I am not satisfied with the information provided.

http://www.computerperformance.co.uk/win8/windows8-administrative-shares.htm

http://www.tomsitpro.com/articles/windows_8-file_sharing-windows_administrative_shares,2-195.html

share|improve this question
    
There is a work around specified in the link you included. –  HackToHell Oct 24 '12 at 14:07
    
What other information do you want that isn't in the links you've given? Solution 3 in the first link seems exactly what you're after. –  George Duckett Oct 24 '12 at 14:31
    
"however I am not satisfied with the information provided" You need to explain this –  Moab Oct 24 '12 at 15:08
    
I was hoping that there was a non "hack" solution around this. I often re-format . install these computers and didn't want to have to enable it this way each time. –  Brado Oct 25 '12 at 14:06
    
With regards to the registry entry you could always export it to a .reg file and simply import it after a reformat to save the effort of opening the registry each time but it is still just as much of a "hack" as there is no official "Enable admin shares" option anywhere –  Graham Wager Oct 25 '12 at 14:15

2 Answers 2

up vote 7 down vote accepted

Note: If the computer is part of a domain, this does not apply as the admin shares are automatically enabled upon joining.

To enable the admin shares for computers in a HomeGroup or Workgroup, you must first ensure that File and Printer Sharing is enabled:

  • In the Desktop, right-click the Network icon in the system tray and click Open Network and Sharing Center:

    Network and Sharing Center Access

  • Click Change advanced sharing settings in the left hand menu:

    enter image description here

  • Under the current profile, find the File and printer sharing section, and click Turn on file and printer sharing:

    enter image description here

  • Click Save Changes and confirm the change if prompted.

Warning - the next section involves changing the Registry. Be extremely careful as incorrect editing can result in a non-functioning system or other problems!

  • Press Windows+R and type regedit followed by Enter. Click Yes to confirm starting it as an Administrator if prompted.

  • On the left hand side expand the tree along the following path:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

  • Select the System folder and in the right hand pane, right click, click New then DWORD (32-bit) Value.

  • Set the name to LocalAccountTokenFilterPolicy then press Enter. Double-click the new entry and set the value to 1.

    LocalAccountTokenFilterPolicy Setting

  • Exit the registry editor and restart the computer.

share|improve this answer
    
I accept your answer even though its the same as in the link, since you at lease spent the time to format it nicely. –  Brado Oct 25 '12 at 14:06
    
@Graham Wager I have a Question: Can I add the specified key in registry using c#. if so, how??? –  kashif Jan 25 '13 at 12:16
    
I wonder if there is a way to do this remotely –  zespri Jun 29 '13 at 8:22

Your first link there has the best solution IMO. Edit the registry and add the right.

http://www.computerperformance.co.uk/win8/windows8-administrative-shares.htm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.