Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 12.04 running MySQL server 5.5.24. I can connect with mysql --user root -p. status shows me :

...
Connection: Localhost via UNIX socket
...

When I try to connect with mysql --host 127.0.0.1 --user root -p (or with --protocol=tcp) I can connect (get a prompt) but anything I'll try to do will get me this error:

ERROR 2006 (HY000): MySQL server has gone away
No connection. Trying to reconnect...
Connection id:    39
Current database: *** NONE ***

ERROR 2013 (HY000): Lost connection to MySQL server during query

netstat -pal | grep -P '3306|mysql' shows:

tcp        0      0 localhost:mysql         *:*                     LISTEN      26535/mysqld    
unix  2      [ ACC ]     STREAM     LISTENING     121787   26535/mysqld        /var/run/mysqld/mysqld.sock
unix  3      [ ]         STREAM     CONNECTED     18810    2252/mysql-workbenc 
unix  3      [ ]         STREAM     CONNECTED     16377    2252/mysql-workbenc 
unix  3      [ ]         STREAM     CONNECTED     18765    2252/mysql-workbenc 
unix  3      [ ]         STREAM     CONNECTED     17959    2252/mysql-workbenc 

Using UNIX sockets I'm able to work just fine. Any ideas?

my /etc/mysql/my.cnf:

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port        = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice        = 0

[mysqld]
#
# * Basic Settings
#
user        = mysql
pid-file    = /var/run/mysqld/mysqld.pid
socket      = /var/run/mysqld/mysqld.sock
port        = 3306
basedir     = /usr
datadir     = /var/lib/mysql
tmpdir      = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address        = 127.0.0.1
#
# * Fine Tuning
#
key_buffer      = 16M
max_allowed_packet  = 16M
thread_stack        = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit   = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries   = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id      = 1
#log_bin            = /var/log/mysql/mysql-bin.log
expire_logs_days    = 10
max_binlog_size         = 100M
#binlog_do_db       = include_database_name
#binlog_ignore_db   = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet  = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

I just found out that the mysqld process crashes every time I'm trying to connect with tcp and run something. I see that in /var/log/syslog and used ps -ef to verify that the PID changes:

Oct 24 16:14:47 desktop kernel: [13190.117685] init: mysql main process (27929) terminated with status 1
Oct 24 16:14:47 desktop kernel: [13190.117685] init: mysql main process ended, respawning
Oct 24 16:14:48 desktop kernel: [13190.212097] type=1400 audit(1351088088.044:124): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=28079 comm="apparmor_parser"
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28123]: Upgrading MySQL tables if necessary.
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28126]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28126]: Looking for 'mysql' as: /usr/bin/mysql
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28126]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28126]: This installation of MySQL is already upgraded to 5.5.24, use --force if you still need to run mysql_upgrade
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28137]: Checking for insecure root accounts.
Oct 24 16:14:50 desktop /etc/mysql/debian-start[28142]: Triggering myisam-recover for all MyISAM tables

This is pretty much like the regular log when I start mysqld but I posted it anyway in case someone get something interesting out of it.

share|improve this question
    
Did you ever resolve this? I am seeing similar behavior –  ashgromnies Apr 29 '13 at 20:55
    
Kind of... My Linux runs in a virtual machine and if I remember correctly restarting vbox on the host resolved this. I also remember seeing something strange in logs (in the client) with the NIC. That was what led me to suspect the virtual layer. –  Zach Moshe Apr 30 '13 at 7:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.