Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've followed the installation instructions on the XAMPP site, set up port forwarding and added firewall rules like described in this question.

I can connect to the server locally using the WAN IP but when trying the exact same thing from outside I am not able to connect to the server.

My port forwarding on my Asus N66U is set up like:

<unusedport1> <pcip> 80 TCP  
<unusedport2> <pcip> 443 TCP

I would expect to be able to go to wanip:unusedport1 and see the index page.

What I've Tried

  • Access the site locally: I am able to go to pcip:80 and access the server as well as using the wanip:unusedport1 and acessing the server.

  • Check ports: I've used this port checker tool and been told that unusedport1 and unusedport2 are open.

  • Checked config files: The Apache config files are set at their default as "Listen 80" and "Listen 443" so they aren't listening for a specific IP.

  • Windows Firewall: I've set up incoming rules for Ports 21,80,443 in Windows Firewall as well as completely turned off the firewall and tried to access the page.

The error I get is "Could not connect to remote server"

Anybody have any suggestions for what else to check and/or try? It should work to forward a non matching port to port 80 correct? As in for wanip port 6403 to pcip port 80.

share|improve this question
add comment

1 Answer

You've opened the ports on the router but I think you will find that Windows is blocking the incoming traffic?

Try temporarily turning off the Windows firewall. IF that works, turn it back on and add rules to allow inbound traffic for ports 80 and 443.

share|improve this answer
    
Thanks for the suggestion, like I said though I've already set up rules in Windows Firewall but I tried your suggestion. I turned it off and still could not connect. How should I be formatting my URL when requesting my home server? http:// xx.xx.xx.xx:xxxx? –  Vian Esterhuizen Oct 24 '12 at 16:01
    
@VianEsterhuizen - It doesn't matter. Update your question to explain what you have tried. –  Ramhound Oct 24 '12 at 16:09
    
I've added all the things I've tried. I've checked the config files, I've checked the Windows Firewall, I've checked my ports are open. I've tried it locally on my local ip. All that is in the question. What else would you like me to add? –  Vian Esterhuizen Oct 24 '12 at 16:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.