Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm surprised I haven't been able to find an answer to this after googling for half-an-hour.

My filename is Default-LandscapeRight@2x.png but it cuts of the filename at the '@' sign (can't find file 'Default-LandscapeRight') within the OSX Terminal when entering a command. I tried escaping it with a slash in front, i tried putting the whole filename in single quotes but it does not do the trick.

Anyone?

Edit: I'm trying to add a file using SVN (Subversion). svn add Default-LandscapeRight@2x.png

share|improve this question

migrated from stackoverflow.com Oct 24 '12 at 15:53

This question came from our site for professional and enthusiast programmers.

    
Same result. Cuts off at @. – Wollan Oct 24 '12 at 13:06
    
    
That did the trick! And I was using SVN yes (add command). Post it as an answer Colonel and I will give it to you. – Wollan Oct 24 '12 at 13:08
up vote 1 down vote accepted

Use @@ to escape the character in SVN:

svn add Default-LandscapeRight@@2x.png
share|improve this answer

Use svn add 'Default-LandscapeRight@2x.png'@HEAD.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .