Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do I get the Modern UI of Firefox in Windows 8?

The latest Nightly build of Firefox claims to have support for the Metro (Modern) UI. How can I change my default Metro browser from Internet Explorer to Nightly?

share|improve this question

marked as duplicate by Journeyman Geek, Karan, Hennes, soandos, akira Oct 25 '12 at 5:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@JourneymanGeek this is not the dupe of that question as here OP is asking how to set it default and the problem not launch in ModernUI after setting it default. –  avirk Oct 25 '12 at 5:04
    
@slhck can you take a look on this question as I don't think this is the dupe of that question As OP is just asking how to set it default an the problem is after setting it default. I think both are diff. –  avirk Oct 25 '12 at 5:18
    
If it was the default, it would launch in modernUI. It dosen't cause the modernUI portion is broken. If you really feel this question should be reopened, consider asking on meta. I VERY strongly feel this is an exact dupe, and the answer dosen't work as is, anyhow. –  Journeyman Geek Oct 25 '12 at 6:05
add comment

1 Answer

up vote 2 down vote accepted

Just go to control panel and select the option "Default Program" now a dialog box will appear select the first option "Set you default programs". Now the list will be load then search out Firefox and select it now you will see the "Set this program as default". See the screen shot as I've set the Chrome to default you can do it for Firefox. That's it.

enter image description here

share|improve this answer
    
I've done this, but any links clicked from Modern-UI open in the desktop version of Nightly. How do I use the Modern-UI version of Nightly? –  Suchipi Oct 24 '12 at 17:45
2  
Right click on the Firefox icon and select the properties. Now in the target after giving a space add -metrodesktop and apply it. Beware don't delete the whole value. –  avirk Oct 24 '12 at 17:47
    
Perfect. Thanks! –  Suchipi Oct 24 '12 at 17:50
    
@Suchipi don't forget to mark it accept if it solve the problem. :P –  avirk Oct 24 '12 at 17:51
    
Does it actually work though? I was testing it earlier and it didn't work - I got the modern UI in the desktop instead –  Journeyman Geek Oct 24 '12 at 23:31
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.