Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Server: smtp.gmail.com Port: 587 Username: myemail@gmail.com Password: mygmailpassword

What is the issue here? My email server does not seem to be working despite turning on POP3 on my gmail account. Also tried turning on both IMAP and POP3..with no luck

P.S. This is being used for OSQA

share|improve this question
1  
do you have any debug output as to exactly y it isnt working? Auth error? Is it even trying to get the mail? etc p.s. OSQA looks like stackoverflows twin :P –  Karthik T Oct 25 '12 at 4:48
    
I am merely putting the values in the settings page on OSQA. Any suggestion on how to get the output? –  sabid15 Oct 25 '12 at 4:55
    
Have you tried what is shown here? Doesnt look very neat but seems to be a similar problem? –  Karthik T Oct 25 '12 at 5:07
add comment

1 Answer

What is the issue here?

The main issue is the absence of diagnostic feedback.

Another issue is that the question's title is about SMTP but the body is about POP3/IMAP. These are different protocols used for different purposes. An SMTP client cannot communicate witha POP3 or IMAP service and vice versa. Most clients use SMTP for sending mail and POP3/IMAP for collecting received email.

Use tcpdump or wireshark to watch OSQA attempting to collect email. Look for errors being reported by Gmail or connection failures.

Use tcpdump or wireshark to watch a normal POP3 or IMAP client communicating with your Gmail account, compare with what OSQA is doing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.