Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use google.com instead of google.com.hk as my default search engine in Chrome. I tried to use custom search engine, but they all break search suggestions, not even something like

https://encrypted.google.com/search?q=%s&{google:RLZ}{google:acceptedSuggestion}
{google:originalQueryForSuggestion}{google:assistedQueryStats}
{google:searchFieldtrialParameter}sourceid=chrome&ie={inputEncoding}

which include parameters like acceptedSuggestion that seems to imply seach suggestions being enabled. But no, search suggestions still don't work.

In addition. some websites suggest editing Local State file under Chrome's setting folder. I already tried that, and it didn't work at all.

So, is there any way to use google.com as default search engine without breaking search suggestions?

share|improve this question

2 Answers 2

If you're using Google.com search as your default search engine in the address bar and you're outside the United States, you may notice that the Google search engine is from a country-specific site (e.g. http://www.google.co.uk in the UK) rather than http://www.google.com. Google uses your computer's IP address and cookies to determine your location and the corresponding Google search engine to use.

If you'd rather use regular Google search in your address bar and force the result in English, follow these steps:

  1. Go to http://www.google.com. If you're redirected to a country-specific site, click the Google.com in English link that's usually located at the bottom of the local Google site. Do a search. This action will save your preference for using the regular Google search engine in a cookie.
  2. Close all your Google Chrome windows to exit the browser completely.
  3. Open a new Google Chrome window.
  4. The Google Chrome address bar should now be set to use the regular Google.com search as your search engine.
share|improve this answer

Here's one way to make search suggestions work, if you have a URL for fetching them.

  1. Set the default search engine as you normally would, then exit Chrome completely

  2. Open the Preferences file in your user profile

  3. Look for default_search_provider_data

  4. Under it, look for template_url_data

  5. Under it, look for suggestions_url, or create it if it does not exist. Set it to a working URL, such as

    "suggestions_url": "https://clients1.google.com/complete/search?client=chrome&hl={language}&q={searchTerms}"
    

    (Don't forget to add a comma at the end if there is another element following it.)

  6. Also set suggestions_url_post_params as appropriate (it can be simply "" for the above URL).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.