Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Got an odd problem here. Installed programs is showing SQL Server 2012 installed, but fails to remove itself when running the uninstaller. To add insult to injury, it also won't let install the components I do want, saying a dependency failed (SQL Client Connectivity SDK), but not being very helpful otherwise.

Anyone else encounter this error / have an idea how to solve it?

share|improve this question
1  
I would reinstall the operating system. Otherwise I would post the error from the installation log. What operating system exactly are you trying to install SQL Server 2012 on? I presume its Windows 7 but very few people tag questions the correct way anymore. –  Ramhound Oct 25 '12 at 11:23
    
It is Windows 7, and there is no error message, save what I've included above. I read another post, which said to uninstall the Azure SDK, but I have no such thing installed. –  user978122 Oct 25 '12 at 14:35

2 Answers 2

up vote 1 down vote accepted

Have you previously installed SQL 2012? Or did you inherit this machine and don't know its history?

Open the SQL Server Configuration Manager, and see if your instance in listed there. If it's not there, then SQL doesn't think it's there, and vice versa.

Next, look for a file like this:

C:\Program Files\Microsoft SQL Server\110\Setup Bootstrap\Log\Summary.txt

Take a look through the file and see if it sheds a clue as to the problem.

You should also see a series of folders for each of the install attempts.

Also, I would try running the setup program and try the repair option.

Another possibility, is to install a new instance with a new name.

For uninstalling, try downloading CCleaner and running the uninstall through that.

share|improve this answer
    
Found the solution. I had SQL 2008 installed (by Visual Studio), and for some odd reason that was causing a conflict. Removing all the SQL 2008 components, then install worked (and I got to run repair on Visual Studio...). –  user978122 Nov 28 '12 at 5:58
    
How can I do uninstall complete for Sql Server 2012? Fails for me: connect.microsoft.com/SQLServer/feedback/details/733652/… and I need unsintall fully –  Kiquenet Nov 16 '13 at 16:59

I ran in to the same problem. I had SQL 2008 Express & needed SQL 2012 Express. I left 2008 on. After installing 2012 I realized I'd installed only the core engine & none of the tools.

Final solution that worked for me:

  1. Uninstall 2008 completely, which I had to do one component at a time in Control Panel - Programs & Features.

  2. Find the core SQL Server app (64-bit in my case) and uninstall it. It shows up like this

    Microsoft SQL Server Server 2012 (64-bit)

The above uninstalled all the 2012 components - I had something like 9 or 10 total entries for SQL Server 2012.

  1. Install SQL Server 2012 Express Advanced. This download includes all the tools & free add-ons. Express does not include Server Profiler...

SQL Server 2012 Express (64-bit) Download options:

  • SQLEXPR_x64_ENU just the database engine, no tools, reporting services or full-text search
  • SQLEXPRWT_x64_ENU WT means With Tools. Database engine with tools (SQL Server Management Studio, Distributed Replay - Admin Tool, LocalDB
  • SQLEXPRADV_x64_ENU Advanced. Database engine with tools plus SSDT, Full-text search, some Reporting services features
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.