Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Cursor lag issue

Introduction

I'm experiencing a newly arrived problem lately that frustrates me a lot. The computer I bought is a Clevo 150ERM. Two of my friends bought the same machine, and are experiencing the same issue.

The computer came with Windows 7. There, I had no issues. Then, when we all switched to Windows 8, they had the mouse problem and I didn't.

That is until after 4 or 5 months when I decided to install the RTM driver of my Intel graphics chip, and the latest Nvidia driver. I also installed the latest version of Skype that just released (Skype 6 and Skype for Metro).

This basically leads me to conclude that the issue is not hardware-prone, and is not based on the operating system itself, rather the drivers or components that follow with it.

Description of the issue

The issue itself (lag with the mouse) happens whenever the cursor icon changes. For instance, if I keep hovering from and to a textfield (and the cursor changes into a caret and then back to a mouse), it stops for 200 milliseconds while it changes the icon.

An example is if I follow the mouse in the pattern shown by the arrows below. When crossing the window border, the cursor changes into a "resize window" cursor for a short while, making the cursor lag. enter image description here

This doesn't sound like much, but it happens every time the cursor changes (even if it's to just move the mouse somewhere else, and accidentally make it cross a window border from where the resize cursor shows etc).

What do you suggest I try?

share|improve this question
2  
It sounds like an issue with your video drivers since before you updated them you didn't have the same problem, can you role them back? –  George Duckett Oct 25 '12 at 11:47
    
I'll try. I'll do a system restore and post the results. –  Mathias Lykkegaard Lorenzen Oct 25 '12 at 11:47
    
In previous version of windows you could roll back individual drivers, I'd try that first (if you can). –  George Duckett Oct 25 '12 at 11:49
    
did you install the intel & NVidia driver from their specific sites or via MS update? –  SnippetSpace Oct 25 '12 at 12:51
    
I also have this problem, definitely bound to Skype. Stupidest thing about this: The lag continues when you close Skype down! Ridiculous! If there is only 1 thing that has to be smooth for me in order to use a OS, it's the cursor. (NVidia GeForce 540M, latest WHQL Windows 8 64-bit drivers) –  René Oct 26 '12 at 17:36

13 Answers 13

up vote 6 down vote accepted

DevDoc's answer made it clear to me that it was the Intel Graphics drivers. And it only happens when multiple screens are connected to the Intel Graphics chip. (By that, I mean that they are connected to either the motherboard video output ports (desktop), or (in my case) any laptop video output)

Rolling back to these drivers (15.28.7.64.2867) worked for me. (Intel i7-2630QM on Windows 8 64-bit)

Check which drivers you need on this page. I suggest simply grabbing the "previously released" drivers.

Edit
I also suggest FIRST trying to update to the newest drivers at the time of reading this, THEN downgrading. By the time of anyone reading this, they may have already fixed it. If so, please post a comment to this answer, and I will update it.

Edit 2
I have found out, that, after a few reboots, the lag randomly appeared again, and contacted Intel support. They weren't of very much help, as I quote: "Please be aware that we provide generic drivers that have not been developed or tested specially for your system.". I personally read this as "Intel obviously has 0 to do with the drivers not working, it's definitely the manufacturer of your laptop..."

I will keep at this, until I find a solution. Meanwhile, I just installed the new 9.17.10.2875 driver, and the issue seems to persist.

Update
According to an Intel official over at the Intel forum topic, the issue has been resolved, and will be included in the next update.

I suggest you guys keep checking the driver download page for an update for your HD Graphics. I would assume getting the update WHQL certified (meaning it'll be automatically updated through Windows Update) will take quite a few weeks. They'll probably release a beta on the driver download page before it comes through Windows Update.

Remember to revert the Group Policy rule of installing Intel drivers, as described in this post, for anyone who applied it in the first place, otherwise it simply won't install.

Update 2
It seems like Intel has fixed the issue!

For some reason, my driver did NOT automatically update through Windows Update though, a manual installation may be required. Download the version appropriate for your CPU here.

share|improve this answer
1  
After rollback, the problem may recur because of automatic driver installation. Blocking display drivers from installing will lock down your system in the usable state: superuser.com/a/525431/43454 –  taoyue Dec 29 '12 at 2:13

For me the workaround was to install the Intel HD Graphics drivers 9.17.10.2770.

I had the same problem with a Samsung Chronos, AMD Radeon HD 6750M + Intel HD Graphics 3000, only with a secondary monitor.

share|improve this answer
    
This worked for me also! Installed the latest, 9.17.10.2875 from here: downloadcenter.intel.com/… –  René Nov 10 '12 at 15:43
    
On further evaluation, the lag has re-occurred... Dealing with it as I type. I really do assume it is related to the NVidia drivers. –  René Nov 11 '12 at 14:34

If you still have this issue: Control Panel > Mouse > PointerOptions >> Uncheck 'Hide pointer while typing'

Fixed it for me and I'm using Windows 8 with multiple screens.

share|improve this answer
    
Thanks, this worked for me! I don't have an Intel graphics card and this was one of the easier solutions to try so I started here. I had been using a USB mouse without issue. Then I connected my MS touch mouse and cursor lag with it was horrible, particularly on the monitor with metro apps. I'll admit I was a little shocked this actually worked. –  Brian Cauthon Jan 14 '13 at 15:20
    
+1 This is by far the best and most clever workaround! Please vote this up! –  Sliq Mar 2 '13 at 14:07

I'd say this was an issue with the video drivers, since only that and skype were installed between the cursor being fine and the cursor being laggy.

As a first try, I'd suggest rolling the graphics drivers back, if you can. Failing that you could try getting the latest drivers from the manufacturers sites specifically, maybe trying the Release Candidate (RC) versions if they have any.

Another option would be to try a system restore, however obviously that's a bit more drastic.

share|improve this answer

This issue is linked with the nVidia drivers newer than 306.97 as that's the latest confirmed-working driver available on Windows Update. I've only tested with 310.33, so anything newer than 306.97 but older than 310.33 might work fine, and 310.33 is still in beta so it's worth informing nVidia about this issue in the hope that a fix can be included when the newest 310.xx driver gets WHQL certified.

EDIT: On further investigation, it appears that there's more to this than previously assumed: It seems that when apps are put on secondary monitor, the problem exists even with 306.97. Can someone confirm this?

EDIT2: Submitted bug report on feedback form to nVidia, waiting to hear back.

share|improve this answer
    
Mathias has dual graphics adapters. Normally, the Nvidia drivers should only kick in when a GPU-intensive application (~=game) is running. While on the desktop, only the Intel driver should be active (to conserve power). So, the issue should not be about Nvidia drivers. Rolling back the Intel drivers would be a better gamble. –  Ishmaeel Nov 6 '12 at 14:20

In my case, it was AMD Radeon HD 7570 + Intel HD 4000.

Rolling back the Intel drivers fixed it -- but only for a couple of days. Uninstalling the drivers from "Programs and Features" also wouldn't stick. For some reason, the updated Intel driver kept reinstalling itself.

I ended up "freezing" the working configuration, so that it cannot be updated. Of course, the first thing to do is to get a working configuration:

  1. Unplug your network cable, turn off WiFi, etc.
  2. Uninstall the updated Intel graphics drivers from Programs and Features.
  3. Reboot and make sure the mouse cursor works properly.

I'm running driver version 9.17.10.2768 (5/26/2012) -- the version bundled with Windows 8 RTM. Thus, I did not have to download or install any driver packages -- I just had to get rid of the Intel updates.

Once you are satisfied, you can then block display drivers from installing:

  1. gpedit.msc
  2. Local Computer Policy -> Computer Configuration -> Administrative Templates -> System -> Device Installation -> Device Installation Restrictions
  3. Set "Prevent installation of devices using drivers that match these device setup classes" to Enabled. In options, enter the device setup class GUID for display drivers: {4d36e968-e325-11ce-bfc1-08002be10318}
  4. Reconnect to the network.

This finally fixed the problem, for good. The nice thing about this method is that it only affects the display drivers -- all other driver classes will continue to update, as before. Note that this setting will also block manual installation of display drivers -- so you will need to first unblock them before attempting an update.

Incidentally, Intel is aware of the mouse cursor problem and is looking into it. Might take some weeks or months to get a resolution, though: http://communities.intel.com/message/174556

Update: Problem has finally been fixed for the Intel HD 4000 in driver version 9.18.10.3071 (3/19/2013)

share|improve this answer
1  
+1 - might help others. –  Mathias Lykkegaard Lorenzen Dec 28 '12 at 23:42
    
Please edit the post to tell people to install the old Intel driver BEFORE adding the rule in gpedit. I made this mistake, resulted in me not being able to install it manually either, until I disabled the rule again. Also, if this post adds the installation of the currently selected answer post's driver, I suggest this one be marked as answer. –  René Jan 2 '13 at 10:22

I noticed this exact problem when I updated the drivers in Windows 7 on my laptop. Seems to be a problem with Intel's latest drivers, rolling back fixed it.

share|improve this answer
    
So, it happened when you installed the newest Intel drivers, you say? Do you even have a NVidia card? –  René Nov 3 '12 at 17:09

I have confirmed this issue through experimentation. I am running an geforce 670 for my main monitor and 2 others off of the onbouard Intel HD3000(2600k). When I change the cursor to the regular one and enable cursor shadows the problem goes away. If I turn off the other monitors on the Intel chip, the problem goes away. I placed the montitors on the Intel so that the power saving features of the nvidia would kick in. I have also tried moving all monitors to the Nvidia which works perfectly as well. I would say this is a strange bug with the Intel driver (latest here) regarding cursor shadows.

share|improve this answer
1  
Since you're not offering an actual solution, you should delete this answer and repost it as a comment. –  Isaac Rabinovitch Nov 24 '12 at 20:08
    
I also see that it's purely with two screens connected... By "moving all monitors to the Nvidia" you mean, switching the connectors so the monitors are connected directly to your video card, instead of the motherboard? Or is there a different way to do this? –  René Nov 26 '12 at 19:25

I have found that turning on pointer trails eliminates the issue completely. Setting the trails to the lowest setting makes them nearly unnoticeable. While this is a pain for gamers since you need to turn off pointer trails in order to see your mouse in game, this is still a fool proof solution to this problem until this issue is sorted out through a software update.

share|improve this answer
    
The first time this stupid feature is finally useful! Thank you! –  DebugErr Feb 22 at 20:18

I have the same problem on laptop (Win 7 Ent. SP1 x64) with Intel HD Graphics 3000 (no other video card) - only when second monitor is attached. Removing the external monitor resolves it.

The cursor lag happens right after upgrade to 9.17.10.2875 drivers from Intel website (latest ones).

share|improve this answer

I had to exact same problem and I managed to solve it (at least temporarily) by going to the mouse settings and changing the text marker. I only changed it to a random icon and then switched back to the default and after that I've not experienced this issue again after several restarts and regular use of the computer. Try playing around with it yourself and see if you get the same result.

share|improve this answer

Another workaround:

  1. Go to Control Panel ⇨ Mouse ⇨ Pointers
  2. Disable pointer shadow (the bug disappears)
  3. Reboot
  4. Re-enable pointer shadow
share|improve this answer

Same problem here with AMD Radeon 6850. I have a projector connected on HDMI and the default screen on DVI.

The problem exists since I connected the additional projector. Enabling cursor trails fixed the problem for me.

share|improve this answer

protected by Community Dec 21 '12 at 0:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.