Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently running a VM using Virtualbox. The VM is Windows 2003 on a Windows 7 host.

I'm currently performing Windows updates on the VM and it's interrupting the audio on the host (and the mouse is jumpy too).

I have a core2Quad with 8GB of RAM with slightly less than 50% available. CPU load is 25% approx on each processors.

Are there ways to limit the impacts of the VM on the host?

Update #1

VM Harddisk is on the same drive as the mp3 that is playing. IMO, it shouldn't matter as the mp3 require little disk access.

I think it might be a bus saturation issue? I have an Asus P5Q-E FWIW.

Update #2

The VM in question had 2GB of RAM allocated to it along with one CPU.

I've turned off host IO cache, execution cap is at 100% with no bandwidth limit imposed. Still lags, the mouse jumps around considerably when the VM does disk IO.

Update #3

This is not a laptop, but my main desktop. All hard drives are plugged in via SATA connectors on the motherboard (and are SATA based too).

I never really run more than one VM at a time.

Each HDD has at least 50GB of free space. The OS is on C: and the VM HDD are on D: (another drive entirely).

I went into Device Manager and all devices seem to be appropriately installed and accounted for (ie. no warning icon).

Update #4

I just noticed that Guest Additions were not installed. Would that help? Based on a quick google, it might?

Update #5

Both of my HDD have passed SMART using Seagate's Seatools. Guest Additions have also been installed.

Update #6

The Guest Additions aren't helping. I'm downloading SQL Server Express 2008 on C:, the VM is running which makes the cursor jump all over the place...

share|improve this question
    
Yes, try installing Guest Additions for sure –  Earlz Oct 25 '12 at 14:23
add comment

2 Answers 2

up vote 0 down vote accepted

There are a couple of settings listed here on the VirtualBox web site. Namely controlling the use of the host disk caching & limiting host IO bandwidth.

Either of these could be having an impact on your host machine.

There is also an "Execution Cap" setting in the VM settings that allows you to restrict the maximum CPU that the VM is allowed to use. You might also like to make sure that you don't allocate all of your CPU's to the guest VM.

Similarly, you may want to play around with how much RAM to allocate to the guest VM - try reducing it so that the host has more RAM available.

share|improve this answer
    
The VM has 2GB of RAM allocated and 1 assigned CPU. I'll read up on that link you provided. –  TekiusFanatikus Oct 25 '12 at 12:47
add comment

Sounds like a hard drive speed problem. I'd make sure of a few things:

  • Make sure you're not allocating too much RAM to the VM and/or running too many things on the host machine. This will cause you to page out a lot of things and will make things very slow
  • Is this a laptop by chance? Laptop harddrives are usually quite a bit slower than desktop harddrives. I know when I power up a virtual machine on my laptop it can really slow it down(though it only interrupts music at VM start up) when compared to my desktop where you can't really tell a VM is even running unless I'm doing something really intense
  • Do you have up to date sound card drivers on your host machine? This could possibly cause this issue

Other than that, I'm not really sure. You might want to use performance monitor and take a look at RAM, CPU, Disk, and Page file usage. If you wan to know what your "max" is for the first three, run a benchmarking program while watching it... then compare it to when a VM is running to figure out how much resources it's using

Finally, you may also try a few other small things.

  • Defragmenting your harddrive (probably won't help unless it's really bad)
  • Make sure you have at least a few gigs free on yoru harddrive
  • Install a new harddrive(make sure it's not a "green" harddrive) for VMs (I can say this really helps with speed)
  • Make sure you're not doing something crazy like using an IDE harddrive
share|improve this answer
    
This is my main desktop, not a laptop. My hard drives have at least 50GB available on each. All my HDD are plugged in using SATA. I haven't checked the fragmentation though. –  TekiusFanatikus Oct 25 '12 at 14:00
    
@TekiusFanatikus are you using "green" or power-saving harddrives? Those type tend to be much cheaper than regular harddrives, but are about 5 times slower as well –  Earlz Oct 25 '12 at 14:21
    
I'm using Seagate Barracuda 7200RPM drives (ST3500320AS and ST3750330AS) –  TekiusFanatikus Oct 25 '12 at 14:28
    
@TekiusFanatikus have you tried running a SMART test on the harddrive to make sure it's not beginning to fail? –  Earlz Oct 25 '12 at 14:30
    
No I have not... I'll try this during the day. –  TekiusFanatikus Oct 25 '12 at 15:21
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.