Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable automatic hyphen correction in OS X 10.7?

When using the spell checker in Apple Mail it is always prompting to correct my hyphens to another one which is essentially similar but microns longer on the screen for some reason.

It's annoying as I often use hyphens and really need spell check too. Thoughts?

I looked in all the usual System Preferences places but can't find anything.

share|improve this question
    
Are you sure you're not using a third-party program to do this? Try creating a new user account to see whether the issue occurs there as well. –  Daniel Beck Oct 25 '12 at 16:24
    
By "the usual System Prefs", did you mean to include Language & Text » Text » Use symbol and text substitution as well? By the way, in standard English, you normally don't use a hyphen except for separating syllables. Most of the time – like here – you'd use an en-dash, which is why the autocorrection does make sense. So, in the first revision of your question, you should have used the en-dash instead of the hyphen as well. –  slhck Oct 25 '12 at 16:25
    
Have you unchecked Edit > Substitutions > Smart Dashes? @slhck It's more common to separate parts of sentences with em-dashes. There's dozens of other uses for normal hyphens as well. The PDF version of the Chicago Manual of Style uses two hyphen-minus characters in place of em-dashes and en-dashes. –  ؘؘؘؘ Oct 26 '12 at 15:25
    
Interesting, but that must be some kind of conversion thing (similar to how LaTeX uses three minus-hyphens to generate an em-dash), because they explicitly promote the use the em-dash. AFAIK most British publishers would use spaced en-dashes, whereas American would use closed em-dashes to set off parts of sentences, so you're correct in that regard. @lauri –  slhck Oct 26 '12 at 15:37

1 Answer 1

If you are using Outlook for Mac or Apple Mail, then you can go to the top menu bar Edit --> Substitutions --> Uncheck Smart Dashes

I had to turn this off for performance reasons on my Outlook 365 for Mac because when editing an email it would perform the smart dash or hypen conversion and then completely lose the cursor. This was majorly disruptive when drafting emails.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.